Permissions on a file

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I create a text file on the server remote.txt ok with the following
code (the last part of it)

$first_name = $FORM;
    $last_name  = $FORM;

open (example, ">remote.txt") || die ("Could not open file. $!");

print example "$first_name\n$last_name\n";

close (example);

print "Content-type:text/html\r\n\r\n";
   This bit causes errors......     chmod
0777,'remote.txt'; ......................................
print "<html>";
print "<head>";
print "<title> Processed</title>";
print "</head>";
print "<body>";
print "<h2>Commands $first_name $last_name - Sent to text file</h2>";
print "</body>";
print "</html>";

The problem is that I need to be able to delete this file remotely
using FTP and the script generate a new version every now and then. I
need teh script to make the file deleteable. How do I do this?
I tried chmod 0777,'remote.txt' and it spews out errors.


Re: Permissions on a file wrote in news:27a86a81-91bd-4d5c-87ff-

Quoted text here. Click to load it

You should always, yes always,

use strict;
use warnings;

Quoted text here. Click to load it

We have been through this once before

my $filename = 'remote.txt';

open my $EXAMPLE, '>', $filename
   or die "Cannot open '$filename': $!";  

Quoted text here. Click to load it

print $EXAMPLE "$first_name\n$last_name\n";

Quoted text here. Click to load it

It is crucial to check for errors on close on a filehandle opened for

close $EXAMPLE or die "Error closing '$filename': $!";

Quoted text here. Click to load it

What errors does it cause?

chmod 0777, $filename
   or die "Cannot chmod on '$filename': $!";

Have you read perldoc -f chmod and perldoc -f umask?

Quoted text here. Click to load it

Don't be silly!

print <<EO_HTML;
<h2>Commands $first_name $last_name - Sent to text file</h2>

Quoted text here. Click to load it

Did you try looking at the error messages?


(remove .invalid and reverse each component for email address)

comp.lang.perl.misc guidelines on the WWW: /

Re: Permissions on a file

Quoted text here. Click to load it

I believe your problem is not a perl issue but a permission issue. The
script is running under a webmaster or other account and the file
created is owned by that creator, yet your ftp access is under a
different account name. If you have shell access, do a ls -l on that
directory to see who is the owner / group, that is who you need to be
to delete it. If you have ftp access as the server admin (versus the
webmaster) you can delete the file then (at least this has been my

I run into this all the time when a client gives me ftp access to
their website and gives me a webmaster account and wants me to update
their stuff that they posted using a different account. Interesting
thing I have seen is that I can most of the time rename what they have
then post my changed files, but can't delete what they have (or
overwrite it).

Back on the perl issue, I did find away around this about 7 / 8 years
ago by using chown on the file after creating it to change who owned
the file from within a perl script.

Bill H

Site Timeline