perl and GDBM and FreeBSD

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I've recently installed FreeBSD 5.3 with Perl 5.8.6
For unknown reasons they (FreeBSD) do not have a GDBM module
available, however they advise to simply re-compile perl
with GDBM native support.

I've done that, and perl compiled without issue.
A "make test" didn't find anything unusual.

However I run a webmail application which uses perl & gdbm
which is called "emu webmail". It now, with this new setup
shows an error message at the bottom of each of it's
generated web pages which appears to be a low-level perl (or
GDBM) complaint which reads:

     Can't cd to : Inappropriate ioctl for device

I recently switched from FreeBSD 4.9, and with THAT version
(perl 5.005_03) they did indeed have a GDBM "module". .. and,
emu webmail worked just fine.

Can anyone offer a suggestion where to begin troubleshooting
this? EMU tech support claims that FreeBSD must have a problem
with their GDBM/perl system. FreeBSD newsgroup doesn't seem
interested in my problem, so I am kinda stuck.

Is there a way (or program available) to run perl & gdbm through
a test suite?

any suggestions will be gratefully received.


Site Timeline