P5NCI Library for AIX

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I downloaded P5NCI-0.30 from CPAN and tried to build it.
I am doing this on AIX platform.

After extracting and cd to P5NCI-0.30, I tried
perl Makefile.PL
and it is working fine.

bash-3.00# perl Makefile.PL
# running Build.PL
Creating new 'MYMETA.yml' with configuration results
Creating new 'Build' script for 'P5NCI' version '0.31'
Unknown 'build_class', defaulting to 'Module::Build'

After that i run make but it is giving below error message.
bash-3.00# make
        /usr/local/bin/perl Build --makefile_env_macros 1
gcc -maix32 -I/usr/local/lib/perl5/5.10.0/aix/CORE -c -D_ALL_SOURCE -
aliasing -pipe -D_LARGE_FILES -O -o src/nci_test.o src/nci_test.c
Use of uninitialized value $baseext in substitution (s///) at /usr/
local/lib/perl5/5.10.0/ExtUtils/CBuilder/Platform/aix.pm line 17.
Use of uninitialized value $args in substitution (s///) at /
usr/local/lib/perl5/5.10.0/ExtUtils/CBuilder/Base.pm line 194.
Insufficient information specified to Mksymlists at /usr/local/lib/
perl5/5.10.0/ExtUtils/CBuilder/Base.pm line 197
make: 1254-004 The error code from the last command is 9.

Does any one use this library on AIX platform?

Re: P5NCI Library for AIX

Quoted text here. Click to load it

I don't, but since P5NCI's Build.PL is unremarkable I suspect this is a
bug in ExtUtils::CBuilder (on AIX). Could you try building something
else straightforward that uses EUCB (DateTime looks like a good
candidate). If it fails in the same way this is an EUCB bug.


Re: P5NCI Library for AIX

Sachin Patil wrote:
Quoted text here. Click to load it

Looks like abandonware to me.
There are open bugs and no bug fix activity.
The code apparently doesn't build on OSX either.

Site Timeline