module installation

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Thanks to Ben's and Michele's advice, I'm reconfirming the modeule

cpan[61]> install Imager

Imager is up to date (0.62).

Indeed the problem may arise because intially I did by:

install Bundle:Imager

following some web "instructions".

and later I also tried:

install GD
install PGPLOT

and so.

When I tried to uninstall them, I went to perl directory but could not find
the modules and therefore could not "delete" them. Now I guess maybe the
installation was not clean and makes the problem happen.

the author's codes are:

use Imager;
  use Imager::Plot;

  $plot = Imager::Plot->new(Width  => 550,
                          Height => 350,
                          GlobalFont => 'ImUgly.ttf');

  my @X = 0..100;
  my @Y = map { sin($_/10) } @X;
  my @Z = map { 1+cos($_/10) } @X;

  $plot->AddDataSet(X  => \@X, Y => \@Z);
  $plot->AddDataSet(X  => \@X, Y => \@Y,
                  style=>{marker=>{size   => 2,
                                   symbol => 'circle',
                                   color  => Imager::Color->new('red'),

  $img = Imager->new(xsize=>600, ysize => 400);
  $img->box(filled=>1, color=>'white');

  $plot-> = 'angst';
  $plot-> = 'time';
  $plot-> = 'Quality time';

  $plot->Render(Image => $img, Xoff => 40, Yoff => 370);
  $img->write(file => "testout.png");

cpan[63]> install Imager:Plot

Running install for module 'Imager::Plot'
Running make for A/AD/ADDI/Imager-Plot-0.09.tar.gz
  Has already been unwrapped into directory
  '/usr/bin/perl Makefile.PL' returned status 65280, won't make
Running make test
  Make had some problems, won't test
Running make install
  Make had some problems, won't install

Site Timeline