Installing Perl Module

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View


I'm not very good with figuring this wtuff out, so I'm hoping someone
can offer some advice.

We need to install some ability to create line charts from Perl.  So,
I'm trying to install DBIx::Chart.  One of the requirements is to
install GD 1.19.

I tried installing that, but when I get to the make command I get
these errors:

/usr/bin/perl GD/ GD/
Extracting (with variable substitutions)
cp GD/ blib/lib/GD/
cp blib/lib/
cp GD/ blib/lib/GD/
cp blib/lib/
AutoSplitting blib/lib/ (blib/lib/auto/GD)
cp GD/ blib/lib/GD/
cp GD/ blib/lib/GD/
/usr/bin/perl /usr/lib/perl5/5.8.5/ExtUtils/xsubpp  -typemap /usr/lib/
perl5/5.8.5/ExtUtils/typemap -typemap typemap  GD.xs > GD.xsc && mv
GD.xsc GD.c
gcc -c  -I/usr/local/include -D_REENTRANT -D_GNU_SOURCE -DDEBUGGING -
fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE -
D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -g -pipe -m32 -
march=i386 -mtune=pentium4   -DVERSION=\"2.39\" -DXS_VERSION=\"2.39\" -
fPIC "-I/usr/lib/perl5/5.8.5/i386-linux-thread-multi/CORE"  -
GD.xs: In function `XS_GD__Image_stringFT':
GD.xs:2211: error: `gdFTEX_DISABLE_KERNING' undeclared (first use in
this function)
GD.xs:2211: error: (Each undeclared identifier is reported only once
GD.xs:2211: error: for each function it appears in.)

I have no clue what all that means or how to solve it.  Can anyone
help?  It would really help me out a lot.


Re: Installing Perl Module

Quoted text here. Click to load it

The C compiler is complaining about some variables, functions or
defines or whatever not being found. Tou find in the README for
the GD module:

  If this module fails to compile and link, you are probably using an
  older version of libgd.  Symptoms of this problem include errors
  about functions not being recognized in the gd.h header file, and
  undefined symbols from the linker.  If you are having this type of
  error, please REMOVE all versions of libgd, gd.h from your system
  and reinstall libgd 2.0.28 or higher.  Do not contact Lincoln for
  help until you have done this.

Your symptoms look exactly like described here. So as a first step
I would do what's recommended, i.e. install the newest version of
libgd available from /.

                              Regards, Jens
  \   Jens Thoms Toerring  ___

Site Timeline