Installing arch-specific PM without shell access

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Good Morning All,

I am hosting my Web site with Yahoo! small business services.  I need
to get a few Perl modules installed that use compiled C code.  I don't
have shell access, however, so I'm having a real hard time.  I tried
the suggestion at [1].  The problem is that Yahoo! has done things to
cripple Perl-based CGI scripts, preventing that tact from working.

Since that didn't work, I tried to figure out what OS and hardware
architecture the Web server is running with the hopes that I could
find a pre-compiled binary version of the Perl modules I need.  To
this end, I ran this script on the server:

#!/usr/bin/perl -w

use POSIX "uname";
use strict;

my ($sysname, $nodename, $release, $version, $machine ) = uname;

print "Content-type: text/plain\n\n";

print "System = $sysname\n";
print "Hostname = $nodename\n";
print "OS Release = $release\n";
print "OS Version = $version\n";
print "Machine Type = $machine\n";

(Using `uname -a` didn't work for similar reasons as above.)  This
produced the following output:

System = FreeBSD
Hostname =
OS Release = 4.11-YAHOO-20061130
OS Version = FreeBSD 4.11-YAHOO-20061130 #0:
Machine Type = i386

From this, I figured that Yahoo! was running FreeBSD 4.11 on an i386
machine.  So, I went to /
and downloaded the necessary modules.  I unpacked and uploaded the
contents, but when I tried to import the module, I got this error:

Can't load '/blog-mt/extlib/auto/Digest/SHA1/' for module
Digest::SHA1: Cannot execute objects on /p12/m/b28
 at /foo/test.cgi line 5
Compilation failed in require at /foo/test.cgi line 5.

So, the dynamically loaded library can't be imported it seems but the
Perl module I uploaded is found in my search path.

Any ideas on how I might get this working?



Travis Spencer


Re: Installing arch-specific PM without shell access

Travis Spencer wrote:
Quoted text here. Click to load it

I think I found your problem.
** Posted from **

Re: Installing arch-specific PM without shell access

Quoted text here. Click to load it

Not helpful.



Travis Spencer

Site Timeline