hang when I run perl -MCPAN -e 'install Net::SSH::Perl'

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I'm trying to get Net::SSH::Perl installed.  I did install
Math::BigInt::GMP, Math::GMP, Math::Pari, and various other modules
without problem.

But when I run "perl -MCPAN -e 'install Net::SSH::Perl'" the whole
thing hangs at this point:

Manifying blib/man3/Net::SSH::Perl::Cipher::DES.3pm
Manifying blib/man3/Net::SSH::Perl::Packet.3pm
Manifying blib/man3/Net::SSH::Perl::Key::RSA.3pm
  /usr/bin/make  -- OK
Running make test
PERL_DL_NONLAZY=3D1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/03-packet......ok 1/10

At this point it consumes none of the CPU, but never completes.  CTRL
+C breaks out and aborts the installation.  I see plenty of posts
about this when searching with Google, but no answer.  Can anyone

I'm using Ubuntu 8.04-32bit i686 arch, perl 5.8.8 that ships with


Re: hang when I run perl -MCPAN -e 'install Net::SSH::Perl'

Quoted text here. Click to load it

I've had the exact same experience with FreeBSD 7.0.  Is there a

Re: hang when I run perl -MCPAN -e 'install Net::SSH::Perl'

Quoted text here. Click to load it

I get the same result here. After a little investigation, it appears to
be a bug in the test suite, but I don't really understand it. What seems
to be happening is

    The test replaces the internal socket handle with a tied FH, so it
    can test what gets sent and received.

    This tied filehandle claims to have a fileno of 255 (but doesn't, of

    This filehandle is passed to an IO::Select instance, which tries to
    select on fd 255.

    This fd isn't open, so the select hangs.

I wonder if the behaviour of select(2) when passed a bitmap not
containing any open filehandles has changed? In any case, I would say
it's clearly a bug: report it to the author, if it hasn't been already.


               We do not stop playing because we grow old;
                  we grow old because we stop playing.

Re: hang when I run perl -MCPAN -e 'install Net::SSH::Perl'

From cpan I got to the same point then <ctrl+c> exited.  I then re-ran
with "force install Net::SSH::Perl".

I'm using Ubuntu JeOS 8.04.1 (32-bit).

Quoted text here. Click to load it

Site Timeline