DBD::Pg installation under Vista

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

i want to access PostgreSQL 8.3 from Perl 5.10.0 under Vista.
Therefore I need the DBD::Pg driver. Because it isn't available on
ActiveState I downloaded a binary version from PgFoundry and installed
it with ppm.

A test script fails since "msvcr80.dll" is missing. Runnig the VisualC+
+-Runtime installer didn't helped, so I copied the file to System32
which worked fine, as a new error "R6034" occured. I copied
pg.dll.manifest to Perl-bin which worked on my XP machine, but not on
Vista. How can I get DBD::Pg running on my Vista computer?


Re: DBD::Pg installation under Vista

Quoted text here. Click to load it

I take it you've now got msvcr80.dll installed in a location where
it's being found ok.
Do you have any additional info on the "R6034" error. (I don't know
what that is.)

As regards the pg.dll.manifest, could it be that it needs to be placed
in perl/site/bin instead of perl/bin ? (It probably depends upon where
pg.dll is located.)


Re: DBD::Pg installation under Vista

Hey Rob,
Quoted text here. Click to load it
Runtime Error!
Program: C:\Perl\bin\perl.exe
An application has made an attempt to load the C runtime library
incorrectly. Please contact the applications's support team for more

And Perl shouts:
install_driver(Pg) failed: Can't load 'C:/Perl/site/lib/auto/DBD/Pg/
Pg.dll' for
module DBD::Pg: load_file:Eine DLL-Initialisierungsroutine ist
fehlgeschlagen [[in English: "dll initialization routine failed"]] at
 C:/Perl/lib/DynaLoader.pm line 202.
 at (eval 9) line 3
Compilation failed in require at (eval 9) line 3.
Perhaps a required shared library or dll isn't installed where
 at test.pl line 14

Quoted text here. Click to load it
Yes, thats right. pg.dll.manifest is placed in C:/Perl/site/lib/auto/
DBD/Pg/. I copied it to C:/Perl/bin and renamed it into
Perl.exe.manifest (i forgot to say that, sorry). I got that tip from
the internet and it worked fine on my XP-Machine, but not on Vista.


Site Timeline