Weird Module Installation Problem on Solaris 10

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

This is kind of a newbie question, which makes me sad, as I've been
using perl and installing modules for nearly two years now. However, it
seems that due to a lack of brain power, I'm missing something basic
yet fundamental.

I set up a new box with Solaris 10 (x86) and am running in to a lot of
@INC problems when installing modules (using CPAN and the plain
makefiles). I've tried this with Solaris' default perl installation, as
well as the perl packages.

For example, when installing the DateTime module, I get these errors:

# /usr/ccs/bin/make test
PERL_DL_NONLAZY=1 /opt/csw/bin/perl "-MExtUtils::Command::MM" "-e"
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
#   Failed test 'use DateTime;'
#   in t/00load.t at line 6.
#     Tried to use 'DateTime'.
#     Error:  Can't locate loadable object for module DateTime in @INC
(@INC contains: /tmp/DateTime-0.2901/blib/lib
/tmp/DateTime-0.2901/blib/arch /opt/csw/lib/perl/5.8.7/auto
/opt/csw/lib/perl/5.8.7 /opt/csw/share/perl/5.8.7
/opt/csw/lib/perl/site_perl /opt/csw/share/perl/site_perl
/opt/csw/share/perl/site_perl /opt/csw/lib/perl/csw
/opt/csw/share/perl/csw /opt/csw/share/perl/csw .) at
/opt/csw/lib/perl/5.8.7/ line 44

My @INC looks correct. DateTime seems to be looking for a loadable
object (a .so file, I presume), yet I can't seem to find that anywhere.
The initial "make" ran okay:

# /usr/ccs/bin/make
cp lib/ blib/lib/
cp lib/ blib/lib/
cp lib/DateTime/ blib/lib/DateTime/
cp lib/ blib/lib/
cp lib/DateTime/ blib/lib/DateTime/
cp lib/DateTime/ blib/lib/DateTime/
Manifying blib/man3/DateTime.3perl
Manifying blib/man3/DateTime::Duration.3perl
Manifying blib/man3/DateTime::Infinite.3perl
Manifying blib/man3/DateTime::LeapSecond.3perl

.... So i would presume that it would find the loadable objects it needs
in blib, but they don't appear to be there.

I appreciate any guidance you all can provide. I'm kind of beating my
head in over what I know will be a silly thing that I should have
thought of.


Re: Weird Module Installation Problem on Solaris 10

Quoted text here. Click to load it

You're right - should have been compiled from DateTime.xs and
placed in blib where it would have been found. But, as you can see from the
output of 'make', no compilation whatsoever took place. That could be
a) there is something wrong with your perl installation;
b) there is a bug in the DateTime Makefile.PL.

What did 'perl Makefile.PL' report ?
Can you successfully build (eg) Math::FFT from CPAN ? (That would
demonstrate that your perl installation is basically ok wrt building


Site Timeline