Re: XML::SAX::ExpatXS

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

Quoted text here. Click to load it

Looking at ExpatXS.xs, I find that line 657 is:

        // -pc -

I expect that is meant to be some sort of comment, but your compiler
doesn't recognize the "//" as denoting comment. (Strictly speaking, I
don't think it's part of the ANSI C standard, so C compilers are not
obliged to recognize the "//", though many of them do.)

Try changing line 657 to:

        /* -pc - */

Assuming that works, you might then like to file a bug report and/or
notify the author.


Re: XML::SAX::ExpatXS

Quoted text here. Click to load it

It's part of the C99 standard, but many compilers still don't support
that (even though it's now 10 years old), and even if they do, it's not
the default. gcc, for example, needs the -std=c99 flag (gcc also is
still quite a bit away from full conformance).


Site Timeline