problem with using the forks module within a daemon setting

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View


I have a program that I have been running via cron that I thought might
be better run by running it as a daemon. When I created some test
daemon programs they all worked. When I placed my program inside of the
while loop, I noticed that the daemon killed its self somehow. I then
figured out that it died just after it tried launching a new fork
process -- and when I commented this out it worked fine.

I made some sample code based on how I am doing this. I have it set to
print output to the screen. I have it below to not use threads. That
will let you see what it is supposed to do. Then, if you uncomment the
'use forks' statement, comment the line beginning with &browserbuilder,
and uncomment the line starting with $=threads you will see what it
does in a threads-based setup.

Can anyone provide any insight in to why this is not working and
perhaps give some advice for what I need to do?


PS> I would like to use forks instead of threads although I have them
both in the program for testing.



use POSIX qw(setsid);


#use forks;
#use threads;
#uncomment one of two above modules to use that package for threading
use strict;

while(1) {

my (@urls,@urls2,$ib,$i);
print "Started at " . `date` . "\n\n";

@urls=qw/1 2 3 4 5 6 7 8 9 10/;

foreach my $xurlid(@urls)

        $i=$ib . $xurlid; #makes each thread object unique by adding
it's url id to '$ib' defined above
        print "about to fork $xurlid thread\n";
        #$=threads->create(\&browserbuilder, $xurlid, 'dave');
        #uncomment above to use thread-based setup
        #uncomment above to use non-thread setup
        push @urls2, $i; #used for checking thread status later
        select(undef, undef, undef, 0.07); #sleep for 70 milliseconds

# Go through each thread and wait for it to close so the program
doesn't exit early
#foreach my $url(@urls2)
# {
#  @ = $->join();
#  print "$url returned: $[0]\n";
# }
print "Ended at " .  `date` . "\n\n";
sleep 10;
#end loop

sub browserbuilder

my $num=shift @_;
my $name=shift @_;

print "\n$name forked $num correctly\n\n";
return 0;


sub daemonize {
    chdir '/'                 or die "Can't chdir to /: $!";
    open STDIN, '/dev/null'   or die "Can't read /dev/null: $!";
#    open STDOUT, '>>/var/log/uu_info.log' or die "Can't write to
/dev/null: $!";
    open STDERR, '>>/var/log/uu_errors.log' or die "Can't write to
/dev/null: $!";
    defined(my $pid = fork)   or die "Can't fork: $!";
    exit if $pid;
    setsid                    or die "Can't start a new session: $!";
    umask 0;

Re: problem with using the forks module within a daemon setting

Quoted text here. Click to load it

Please don't multipost.  See my response in comp.lang.perl.misc


-------------------- http://NewsReader.Com/ --------------------
Usenet Newsgroup Service                        $9.95/Month 30GB

Re: problem with using the forks module within a daemon setting

Sorry Xho -- after I posted it here I thought it would be better in the
.misc group. I couldn't find how to delete it. I'll post there first
next time. Thanks for your help. wrote:
Quoted text here. Click to load it

Site Timeline