problem with ppm - looking for MSWin320-x86-multi-thread-5.8

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I am using perl with Windows XP and ActiveState Perl.
I downloaded, unzipped it which gave
me a .ppd and .tar.gz file but when I tried to install it
I got this the message below about an MSWin320-x860-multi-thread-5.8
directory.  I also tried using ./finance-yahooquote.ppd in
the ppm command and also the absolute path name but all gave the
same result.

I finally created the MSWin320... folder and put the two files in
there and then it worked.  What I would like to know is why
it is doing this?

I have included a transcript, a dump of the .ppd file and the
output of perl -V below.


1. Transcript of session

C:\tmp2\tmp>ppm install -force finance-yahooquote.ppd
could not find ParserDetails.ini in C:/perl/site/lib/XML/SAX
could not find ParserDetails.ini in C:/perl/site/lib/XML/SAX
Note: Package 'finance-yahooquote' is already installed.
Install 'finance-yahooquote' version 0.20 in ActivePerl
Error: error downloading
e-yahooquote-0.20.tar.gz': 404 File
nance-yahooquote-0.20.tar.gz' does not exist

2. ppd file looks like this:

<?xml version="1.0" encoding="UTF-8"?>
<SOFTPKG NAME="finance-yahooquote" VERSION="0,20,0,0">
HREF="MSWin32-x86-multi-thread-5.8/finance-yahooquote-0.20.tar.gz" />
    <ARCHITECTURE NAME="MSWin32-x86-multi-thread-5.8" />
    <OS NAME="MSWin32" />
  <ABSTRACT>Gets stock quotes from Yahoo! Finance</ABSTRACT>

3. The output of perl -V is:

Summary of my perl5 (revision 5 version 8 subversion 4) configuration:
    osname=MSWin32, osvers=4.0, archname=MSWin32-x86-multi-thread
    hint=recommended, useposix=true, d_sigaction=undef
    usethreads=undef use5005threads=undef useithreads=define
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=undef use64bitall=undef uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
    cc='cl', ccflags ='-nologo -Gf -W3 -MD -Zi -DNDEBUG -O1 -DWIN32
    optimize='-MD -Zi -DNDEBUG -O1',
    ccversion='', gccversion='', gccosandvers=''
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
    d_longlong=undef, longlongsize=8, d_longdbl=define, longdblsize=10
    ivtype='long', ivsize=4, nvtype='double', nvsize=8,
Off_t='__int64', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='link', ldflags ='-nologo -nodefaultlib -debug -opt:ref,icf
-libpath:"C:\Perl\lib\CORE"  -machine:x86'
    libs=  oldnames.lib kernel32.lib user32.lib gdi32.lib winspool.lib
comdlg32.lib advapi32.lib shell32.lib ole32.lib oleaut32.lib
netapi32.lib uuid.lib wsock32.lib mpr.lib winmm.lib  version.lib
odbc32.lib odbccp32.lib msvcrt.lib
    perllibs=  oldnames.lib kernel32.lib user32.lib gdi32.lib
winspool.lib  comdlg32.lib advapi32.lib shell32.lib ole32.lib
oleaut32.lib  netapi32.lib uuid.lib wsock32.lib mpr.lib winmm.lib
version.lib odbc32.lib odbccp32.lib msvcrt.lib
    libc=msvcrt.lib, so=dll, useshrplib=yes, libperl=perl58.lib
  Dynamic Linking:
    dlsrc=dl_win32.xs, dlext=dll, d_dlsymun=undef, ccdlflags=' '
    cccdlflags=' ', lddlflags='-dll -nologo -nodefaultlib -debug
-opt:ref,icf  -libpath:"C:\Perl\lib\CORE"  -machine:x86'

Characteristics of this binary (from libperl):
  Locally applied patches:
      ActivePerl Build 810
      22751 Update to 1.25
      21540 Fix backward-compatibility issues in
  Built under MSWin32
  Compiled at Jun  1 2004 11:52:21

Re: problem with ppm - looking for MSWin320-x86-multi-thread-5.8

Quoted text here. Click to load it

See the line beginning "<CODEBASE HREF= "MSWin...." ?
That's saying that the file finance-yahooquote-0.20.tar.gz is in the
MSWin32-x86-multi-thread-5.8 folder.

So ... if you're current directory is C:\tmp2\tmp\, then the ppd file needs
to be in C:\tmp2\tmp\ (which it is) and finance-yahooquote-0.20.tar.gz needs
to be in the C:\tmp2\tmp\MSWin32-x86-multi-thread-5.8\ folder (which, I'm
guessing, it is not).

Alternatively, you could leave finance-yahooquote-0.20.tar.gz in the current
directory and just amend the "<CODEBASE HREF..." line to:
<CODEBASE HREF="finance-yahooquote-0.20.tar.gz" />


Re: problem with ppm - looking for MSWin320-x86-multi-thread-5.8

Thanks very much for the info.

Re: problem with ppm - looking for MSWin320-x86-multi-thread-5.8

Thanks very much for the info.

Site Timeline