Problem with MIME-tools 5.414 not finding encode_qp

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I am trying to upgrade to MIMEDefang 2.45 and I get the error:
        Undefined subroutine &MIME::QuotedPrint::encode_qp called at
        /usr/lib/perl5/site_perl/5.8.0/MIME/Decoder/ line 75.

I can reproduce the problem with a simple perl script:

        #use MIME::QuotedPrint;
        use MIME::Decoder::QuotedPrint qw(encode_qp);

        while (<>) {
            print encode_qp($_);

If I run it with only the MIME::Decoder::QuotedPrint module then I get the
same error, but if also use the MIME::QuotedPrint module then it works.

I find this perplexing because in the MIME::Decoder::QuotedPrint module it
calls MIME::QuotedPrint.
line 57:        use MIME::QuotedPrint 3.03;

The routine encode_qp is actually a binary routine from the library (?):

So it seems that for some reason the library function is not being inherited
from MIME::QuotedPrint by MIME::Decoder::QuotedPrint.  (I am not a perl
expert so the verbage may be wrong)

Does anyone know how to fix this.  The MIMEDefang mailing list has not
been helpful.  David Skoll said to check that there were no traces of the
older version of the package and I have done this to no effect.

I am running this on Red Hat 9.0 with:
perl                : 5.8.0
MIME::Base64        : 3.05
MIME::QuotedPrint   : 3.03
MIME::Decoder::QuotedPrint: 5.414
MIME-tools          : 5.414

Any pointers would be a help

Site Timeline