Problem compiling Tk-804.027

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View


I'm trying to install Tk-804.027 on Cygwin on a Windows 2000 machine.
'make' fails at this line with the following error:

Quoted text here. Click to load it
gcc -c  -I.. -I../pTk/mTk/xlib -DPERL_USE_SAFE_PUTENV
-pipe -I/usr/local/include -DUSEIMPORTLIB -O3  -DVERSION=\"804.027\"
-DXS_VERSION=\"804.027\" "-I/usr/lib/perl5/5.8/cygwin/CORE"
-D_WIN32 -Wall -Wno-implicit-int -Wno-comment -Wno-unused
In file included from ../pTk/tkWinPort.h:19,
                 from ../pTk/tkPort.h:28,
                 from Xlib.xs:7:
.../pTk/mTk/xlib/X11/Xlib.h:1206:35: ../pTk/tkIntXlibDecls.h: No such
or directory
Quoted text here. Click to load it

Here are the locations of the tkIntXlibDecls.h file in my Tk-804.027

$ find -name tkIntXlibDecls.h

What is going on here?

Thank you,


Paul Cantalupo
Research Specialist/Systems Programmer
559 Crawford Hall
Department of Biological Sciences
University of Pittsburgh
Pittsburgh, PA 15260
Work: 412-624-4687
Fax: 412-624-4759

Re: Problem compiling Tk-804.027

Quoted text here. Click to load it

I remember that there's some problem with wrongly used or defined
macros (WINDOWS? __CYGWIN__?). Unfortunately, other than using 800.025
I don't know any solution.


Slaven Rezic - slaven <at> rezic <dot> de

Lost in your Tk widget tree? Try /

Re: Problem compiling Tk-804.027

Quoted text here. Click to load it

I found the same problem on Win32.

To fix it, in Xlib.h I changed:

#include "../pTk/tkIntXlibDecls.h"


#include "../../../pTk/tkIntXlibDecls.h"

A little later on, I had another problem. PNG/libpng/libpng.a does not get
built. I don't know why that happens. The makefile runs the following
command, which should do the job:

ar rcs libpng.a png.o pngerror.o pngget.o pngmem.o pngpread.o pngread.o
pngrio.o pngrtran.o pngrutil.o pngset.o pngtrans.o pngwio.o pngwrite.o
pngwtran.o pngwutil.o

When that failure occurs, the 'make' process aborts. I then went into the
PNG/libpng folder and ran that same 'ar ....' command - which built
libpng.a. Then back to the top level Tk-804.027 folder and run 'make' again.
The process then ran to a successful conclusion, and 'make test' passed all
tests. (I'm using 'dmake' instead of 'make', but I don't think there's any
relevance in that.)



Re: Problem compiling Tk-804.027

I tried what you suggested but I didn't get the libpng.a error. I got
an error as was seen by Guido
( ).

Has anyone solved this yet?

Thank you,


Re: Problem compiling Tk-804.027

Quoted text here. Click to load it
Quoted text here. Click to load it

Looks to me that Guido didn't get it quite right. (S)he has written:


For me, it needed to be:


I don't think that has any bearing on the problem, however - probably just a
typo in Guido's post.

In short, I can't reproduce your error - and therefore can't fix it. I've
looked at the Xlib.xs errors reported in Guido's post and can't even relate
them to what appears in Xlib.xs.

eg, Guido's post reports the following error:

Xlib.xs:378: error: `XlibVtab' undeclared (first use in this function)

I cannot find the string XlibVtab anywhere within Xlib.xs. I also can't find
a function named boot_Tk_Xlib or the string tabSize. Does this  file get
rewritten under Cygwin ??

I'm compiling with gcc-3.4.4 (albeit a native Win32 port of it) so it's
probably not a gcc-related problem, though there's no guarantee of that.

Once again, I'm glad I don't use Cygwin :-)


Site Timeline