PerlMagick - Annotate - no fonts

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I've read numerous related posts but can't seem to find the solution
I'm seeking.

I have 2 web sites on web hosts.  On host #1, I can use Annotate with
no problem.
If I run QueryFonts, I see a ton listed.

On host #2, images render with ImageMagick, but Annotate doesn't work.
I run QueryFonts and nothing is found.

How do I install fonts so that my perl scripts using Annotate work


Re: PerlMagick - Annotate - no fonts

[A complimentary Cc of this posting was sent to
Quoted text here. Click to load it

I know nothing about PerlMagick, but fought with ImageMagick during
the last couple of days; the documentation is not spectacular...

ImageMagick looks for file(s?) `type.xml' on a certain list of
directories (see "Resources" on the Web page).  Found file(s?) are
interpreted as a mapping from font names/attributes to a font file
name (something else happens on Win32, since the example file has no
directory part of the font name...).

Giving `-debug all' gets you some feedback on this process; you should
be able to find what differs between these systems.

Hope this helps,

Site Timeline