Perl6::Rules character class Segmentation Fault

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

When running 'make test' on Perl6::Rules version 0.03, I found that
several tests died dubiously.  The tests appear to have died when a
character class (<ident>, etc.) was used.

I installed Perl6::Rules and ran the debugger on one of test scripts,
to try to find the cause of my Segmentation Fault.  Unfortunately, I
was unable to find the line that triggered the fault, because the
debugger ran the test perfectly!

I ran the debugger twice, once line-by-line, where I found some tests
were 'not ok' and some tests were 'ok', and once by hitting 'c' at the
beginning, and all tests passed.

While the behavior of the debugger is disconcerting, what I am really
seeking is an action I can take so that Perl6::Rules does not segfault
when examining character classes.

I found one post by Martin Streicher at Sat, 24 Apr 2004 17:04:31 GMT
entitled 'Re: Troubles with Perl6::Rules', in which he states that:

> My error seemed to stem from using
> the older version of Perl instead of the new one (placing the new path
> ahead of everything else worked it out.

I have several perl binaries, but am using the most recent of them.  I
wondered if some module needs to be recompiled.  My @INC appears to
have some older paths in it.

I am including below some detailed information about the situation.



$ perl -V
Summary of my perl5 (revision 5 version 8 subversion 4) configuration:
    osname=linux, osvers=2.4.26-ti1211,
    uname='linux kosh 2.4.26-ti1211 #1 sat apr 24 14:46:58 est 2004
i686 gnulinux '
    config_args='-Dusethreads -Duselargefiles -Dccflags=-DDEBIAN
-Dcccdlflags=-fPIC -Darchname=i386-linux -Dprefix=/usr
-Dprivlib=/usr/share/perl/5.8 -Darchlib=/usr/lib/perl/5.8
-Dvendorprefix=/usr -Dvendorlib=/usr/share/perl5
-Dvendorarch=/usr/lib/perl5 -Dsiteprefix=/usr/local
-Dsitearch=/usr/local/lib/perl/5.8.4 -Dman1dir=/usr/share/man/man1
-Dman3dir=/usr/share/man/man3 -Dsiteman1dir=/usr/local/man/man1
-Dsiteman3dir=/usr/local/man/man3 -Dman1ext=1 -Dman3ext=3perl
-Dpager=/usr/bin/sensible-pager -Uafs -Ud_csh -Uusesfio -Uusenm
-Duseshrplib -Dd_dosuid -des'
    hint=recommended, useposix=true, d_sigaction=define
    usethreads=define use5005threads=undef useithreads=define
    useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
    use64bitint=undef use64bitall=undef uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
-DDEBIAN -fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE
-fno-strict-aliasing -I/usr/local/include'
    ccversion='', gccversion='3.3.3 (Debian 20040429)',
    intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=1234
    d_longlong=define, longlongsize=8, d_longdbl=define,
    ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t',
    alignbytes=4, prototype=define
  Linker and Libraries:
    ld='cc', ldflags =' -L/usr/local/lib'
    libpth=/usr/local/lib /lib /usr/lib
    libs=-lgdbm -lgdbm_compat -ldb -ldl -lm -lpthread -lc -lcrypt
    perllibs=-ldl -lm -lpthread -lc -lcrypt
    libc=/lib/, so=so, useshrplib=true,
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E'
    cccdlflags='-fPIC', lddlflags='-shared -L/usr/local/lib'

Characteristics of this binary (from libperl):
  Built under linux
  Compiled at May 11 2004 23:53:34

Site Timeline