Override System Module With Newer Local Version (noob)

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I am trying to install bugzilla on my web host.
Needless to say I don't have root access.
I have set up a local perl directory for modules ~/perl and I have set
and exported PERL5LIB so that it points to the local lib directory.
I am using CPAN to install the modules.
I am brand new to CPAN and modules so bear with me...
Installing new modules works fine but installing newer versions of
existing modules is not happening.
e.g. Bugzilla needs File::Spec v0.84 the system has v0.82
I can't seem to get 0.84 to install (even with force).
I suspect this could be because:

1. v0.82 is the latest version for my version of Perl (5.6.1). Does CPAN
work this way? Do I need a newer version of Perl to get the latest
version of the modules?


2. v0.82 is new enough and because it is already installed it is not


3. v0.84 simply isn't on CPAN yet and I'll have to install it manually?

Q: Which of the above (if any) is the case?

Q: m File::Spec seems to list the installed module version rather than
the CPAN version. Is there anyway of getting the CPAN version?

Q: Is it acutally possible to override existing older modules with newer

Q: (Finally) My .bash_profile exports PERL5LIB but I have a nasty
feeling this will have no affect on bugzilla which is not run from an
interactive shell. Is there an alternative without having to go through
and add use statements to all the files in Bugzilla.

Thanks in advance,


Site Timeline