New Module name (IO priority)

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I am writing a new module to give access to the (linux only, at the
moment) ioprio_get(2) and ioprio_set(2) functions having not found one
already on CPAN.

Could I have some advice on naming it. IO::Priority doesn't seem right as
most of IO:: is actually file handle IO and this relates to disk IO. CPAN
doesn't want Sys:: to be used so Sys::IO_Prio seems to be not right

I am also considering whether to do a thin wrapper around which follows
the C API closely, or something at a higher level, say with separate
functions set_process_iopriority(), set_pgrp_iopriority(),

This is my first attempt at writing a module, so I would appreciate some
advice from those more experienced.

Many thanks


Re: New Module name (IO priority)

On 11/07/2011 03:46 PM, Mark Hindley wrote:
Quoted text here. Click to load it

Since the API is called ioprio, the easiest to remember name would be

It's about IO priority, so it's a good name, regardless if the other IO
modules handle file IO mostly.

Site Timeline