lib/$archname not included automatically on RedHat box

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!


I am installing an architecture dependent module on a RedHat box. This
module has a Makefile.PL based on MakeMaker and the install sequence:

perl Makefile.PL LIB=/home/foo/lib/
make test
make install

completes without any complaint. Note that the make test is extensively
testing the module and everything looks ok.

Now when I run a final check:

perl -I/home/foo/lib -e "use MyModule;"

i get the following error message:

"Can't locate loadable object for module MyModule in @INC ...."

However if I run:

perl -I /home/foo/lib/i386-linux-thread-multi/ -e "use MyModule;"

everything works just fine

My understanding is that perl should automatically be looking into
"lib/$archname" if "lib" is in the @INC. The installation process
described above works just fine on the Fedora / Gentoo boxes I've been
using thus far ... so I'm wondering what is different with the RedHat

thanks for reading,


Site Timeline