Install DBD::Oracle crashes

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

This is in regards to my previous long winded question regarding
installing DBD::Oracle
Well, I started from scratch and just untarred the binaries.
I am running HP 11.00 B.11.00 U 9000/785
Installed both 64 bit gcc and Perl with DBI
Corrected the correct $PATH:

Here is where my issues arrises...
When I start the install of the DBD:Oracle

Using DBD::Oracle 1.19.
Using DBD::Oracle 1.19.
Using DBI 1.46 (for perl 5.008006 on PA-RISC2.0-LP64) installed in
Writing Makefile for DBD::Oracle

Then it poops out:

ld: Can't find library or mismatched ABI for -lclntsh
Fatal error.
*** Error exit code 1

Would this be because the oracle installed is 32 bit?
Or changing the LD_LIBRARY_PATH will fix this...

How would I do this?

Re: Install DBD::Oracle crashes

Quoted text here. Click to load it

Most probably that is the issue. Your message indicated use of
Oracle client libraries for 8.1.7 database. Do you have a strict
reason for using them? If youd databases are of version
or later, you should be able to use the client libraries for
Oracle 10g ("Oracle Instant Client" package appears to be
available also for hppa64).
Wolf  a.k.a.  Juha Laiho     Espoo, Finland
(GC 3.0) GIT d- s+: a C++ ULSH++++$ P++@ L+++ E- W+$@ N++ !K w !O !M V
         PS(+) PE Y+ PGP(+) t- 5 !X R !tv b+ !DI D G e+ h---- r+++ y++++
"...cancel my subscription to the resurrection!" (Jim Morrison)

Site Timeline