Image::Magick newbie

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

      Hopefully, this will be easy for someone else:

perl Makefile.PL LIB=xx PREFIX=xx
went off okay.


Magick.xs was throwing up a lot of errors with "make" until I did this


MAGICK_HOME = /home/magnolia/ananth/tools/ImageMagick-6.2.4
-I$(MAGICK_HOME)/include to th INC list
in the Makefile

with that done, "make" finished reporting a lot of warnings from Magick.c
Magick.c:7625: warning: unused variable `ix'
Magick.c: In function `XS_Image__Magick_QueryFont':
Magick.c:7700: warning: unused variable `ref'
Magick.c:7695: warning: unused variable `ix'
Magick.c: In function `XS_Image__Magick_QueryFontMetrics':
Magick.c:7815: warning: unused variable `ref'
Magick.c:7810: warning: unused variable `ix'
Magick.c: In function `XS_Image__Magick_QueryMultilineFontMetrics':
Magick.c:8173: warning: unused variable `ref'

then, when I do "make test" every test fails. I get errors like :

PERL_DL_NONLAZY=1 /usr/local/bin/perl "-MExtUtils::Command::MM" "-e"
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/bzlib/*.t t/jng/*.t
t/jpeg/*.t t/mpeg/*.t t/png/*.t t/ps/*.t t/tiff/*.t t/ttf/*.t t/x/*.t
t/xfig/*.t t/zlib/*.t
t/blob............Can't load
for module Image::Magick: /usr/local/bin/perl: fatal:
relocation error: file
symbol AcquireMagickMemory: referenced symbol not found at
/usr/local/lib/perl5/5.8.3/sun4-solaris/ line 229.
 at t/blob.t line 7
Compilation failed in require at t/blob.t line 7.
BEGIN failed--compilation aborted at t/blob.t line 7.
       Test returned status 255 (wstat 65280, 0xff00)
       Failed 1/1 tests, 0.00% okay

Any help you could give me, I'd really appreciate.


PS: tee = t and dot = . in email addr.

Re: Image::Magick newbie

Quoted text here. Click to load it

I don't think there's anything to worry about in those warnings - they're
just telling you that a variable has been declared, and then not used -
which won't really matter at all.
Quoted text here. Click to load it
Quoted text here. Click to load it
Quoted text here. Click to load it

When perl "Can't load" one of its shared objects (, in this
instance), it's usually because of a problem with another shared object upon
which the perl shared object ( depends. Perhaps an ImageMagick
shared object is not being found, or there's a problem with the permissions
of an ImageMagick shared object. Or it could be that there's a mismatch
between the versions of PerlMagick and ImageMagick - though I would expect
such a mismatch would have been uncovered at an earlier stage in the build
process. (Check the PerlMagick Readme anyway.) And there are no doubt other
possibilities as well.

Couldn't find much when googling for "AcquireMagickMemory" (which is the
specific ImageMagick function that seems to be throwing a spanner in the
works), but check out:

I know it's not much to go on, but I hope there's something there that


Site Timeline