HTTP::Proxy and not using

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I am getting great results with HTTP::Proxy - as long as I use as the proxy address in a browser on the same machine.

I would like to have a lan-available proxy so have tested with using
the machine ip it is running on:, but the proxy doesn't
get contacted, even by a browser on the local machine.

I feel sure this is an easy problem, but the things I have tried so far
haven't fixed it for me:

my $proxy = HTTP::Proxy->new( PeerAddr =>'',port => 8080 );
my $proxy = HTTP::Proxy->new( LocalAddr=>'',port => 8080 );
my $proxy = HTTP::Proxy->new( MultiHomed =>1,port => 8080 );

Any suggestions gratefully received.

If it matters, I am using a WinXP machine with Activestate ActivePerl
5.8.8 build 816. The MS-Firewall has port 8080 unblocked.


Re: HTTP::Proxy and not using

If you haven't already, check the firewall on the remote machine.
It's probably blocking incoming connections on that port.

Re: HTTP::Proxy and not using

Just cracked it:

my $proxy = HTTP::Proxy->new( host=>'',port => 8080 );

Site Timeline