How can I install the DBI on Solaris

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Here are what I have been trying to install DBI module on my Solaris 8

1) I'd tried using different perl version.  i.e. 5.8.0, 5.8.3. (they
are all precompiled pkg from

2) I'd tried different versions of gcc and make

3) install DBI like this: /usr/bin/perl -MCPAN -e 'install "DBI"'

4) downloaded the DBI bundle from and compiled it like this:
perl Makefile.PL && make && make test && make install.

No matter what ways I tried, I am the installation would fail (see the
error mesg below)

Could someone give me some light on this?  thanks in advance.....

/usr/local/lib/perl5/5.8.0/sun4-solaris/CORE/proto.h:1378: warning:
data definition has no type or storage class
/usr/local/lib/perl5/5.8.0/sun4-solaris/CORE/proto.h:1379: error: parse
error before "off64_t"
In file included from DBIXS.h:19,
                 from Perl.xs:5:
/usr/local/lib/perl5/5.8.0/sun4-solaris/CORE/perl.h:3926:24: sys/ipc.h:
No such file or directory
/usr/local/lib/perl5/5.8.0/sun4-solaris/CORE/perl.h:3927:24: sys/sem.h:
No such file or directory
/usr/local/lib/perl5/5.8.0/sun4-solaris/CORE/perl.h:4036:21: fcntl.h:
No such file or directory
In file included from Perl.c:59:
Driver_xst.h: In function `dbdxst_bind_params':
Driver_xst.h:55: warning: implicit declaration of function `sprintf'
Perl.c: In function `boot_DBD__Perl':
Perl.c:1085: warning: implicit declaration of function `strcmp'
make: *** [Perl.o] Error 1
  /usr/ccs/bin/make  -- NOT OK
Running make test
  Can't test without successful make
Running make install

Site Timeline