help with an module!!

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View


i need some help. i'm trying to convert three small webbbs forums over
to a phpbb forum. i'm using the webbbs_to_phpbb converter found here
< on my apple powerbook. (my web provider
hasn't been any help, so i'm trying to do this at home.)

anyway, when i run the converter, i get this error:

Can't locate in @INC (@INC contains:
/Library/Perl/5.8.6/darwin-thread-multi-2level /Library/Perl/5.8.6
/Library/Perl /Network/Library/Perl/5.8.6/darwin-thread-multi-2level
/Network/Library/Perl/5.8.6 /Network/Library/Perl
/System/Library/Perl/Extras/5.8.6 /Library/Perl/5.8.1 .) at
/Library/WebServer/CGI-Executables/ line 9.

BEGIN failed--compilation aborted at
/Library/WebServer/CGI-Executables/ line 9.

Line (8 and) 9 of the script calls for:

# for bbcode_make_uid
use MD5;

i gather that the is a module for perl? i'm a novice with perl
and this is very much above my abilities. there appear to several MD5
modules at any idea which one this might be, and how i can
install it on my powerbook?

many thanks for any help!


Re: help with an module!!

Quoted text here. Click to load it

As you will have root-access on your computer, it should be easy:

root@computer# cpan
cpan shell -- CPAN exploration and modules installation (v1.7601)
ReadLine support enabled

cpan> install MD5
  /usr/bin/make install  -- OK
cpan> exit

If you haven't used the CPAN-shell before, it will ask you some
questions about the settings. The defaults will be OK in most cases.

If you haven't the "cpan" executable in your PATH, you can also run it
like this:

perl -MCPAN -e shell



Re: help with an module!!

It worked. Thanks, Thomas!

Quoted text here. Click to load it

Site Timeline