install woes

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I've been trying to install for a few days now, but to no avail.

I am using Fedora Core 2 with a P4 system.

I have installed libgd 2.0.28, Free Type 2.1.9, libpng 1.2.7, and
jpeg-6b. All were installed from source. I gave each it's own
directory under /usr/local/. There were no errors during the install
of any of them. I can use the scripts that get put into the bin
directory by libgd (such as webpng) so I know libgd is working.

My problem arrises when installing I am attempting to install 2.16. I am using the following args with Makefile.PL, although I
have tried many other variations (such as without "/lib" at the end of
the paths):

perl Makefile.PL -lib_gd_path /usr/local/gd/lib -lib_png_path
/usr/local/libpng/lib -lib_jpeg_path /usr/local/jpeg/lib -lib_ft_path
/usr/local/freetype2/lib -options "GD_JPEG,GD_FREETYPE,GD_PNG,GD_GIF"

This gives me the following output:

Configuring for libgd version 2.0.28.
Included Features:          GD_JPEG,GD_FREETYPE,GD_PNG,GD_GIF
GD library used from:       /usr/local/gd/lib
FreeType library used from: /usr/local/freetype2/lib
PNG library used from:      /usr/local/libpng/lib
JPEG library used from:      /usr/local/jpeg/lib
If you experience compile problems, please check the @INC, @LIBPATH
and @LIBS
arrays defined in Makefile.PL and manually adjust, if necessary.
Writing Makefile for GD

Ok, so far so good! I then run make...

gcc -c  -I/usr/local/jpeg/lib/include -I/usr/local/libpng/lib/include
-I/usr/local/freetype2/lib/include -I/usr/local/include -D_REENTRANT
-I/usr/include/gdbm -O2 -g -pipe -march=i386 -mcpu=i686  
-DVERSION=\"2.16\" -DXS_VERSION=\"2.16\" -fPIC
"-I/usr/lib/perl5/5.8.3/i386-linux-thread-multi/CORE"  -DHAVE_JPEG
Running Mkbootstrap for GD ()
chmod 644
rm -f blib/arch/auto/GD/
gcc  -shared -L/usr/local/lib GD.o  -o blib/arch/auto/GD/  
-L/usr/local/freetype2/lib -L/usr/local/libpng/lib
-L/usr/local/jpeg/lib -L/usr/local/lib -ljpeg -lfreetype -lpng -lz -lm
chmod 755 blib/arch/auto/GD/
cp blib/arch/auto/GD/
chmod 644 blib/arch/auto/GD/
Manifying blib/man3/GD::Polyline.3pm
Manifying blib/man3/GD.3pm

Still no problems that I can see. However, make test blows up...

PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
t/GD..........Can't load './blib/arch/auto/GD/' for module GD:
[ cannot open shared object file: No such file or directory
at /usr/lib/perl5/5.8.3/i386-linux-thread-multi/ line
] at t/GD.t line 13
Compilation failed in require at t/GD.t line 13.
BEGIN failed--compilation aborted at t/GD.t line 13.
        Test returned status 255 (wstat 65280, 0xff00)
Scalar found where operator expected at (eval 152) line 1, near "'int'
        (Missing operator before   $__val?)
DIED. FAILED tests 1-10
        Failed 10/10 tests, 0.00% okay
t/Polyline....Can't load
'/home/x3v0/gt/install/GD-2.16/blib/arch/auto/GD/' for module GD:
[ cannot open shared object file: No such file or directory
at /usr/lib/perl5/5.8.3/i386-linux-thread-multi/ line
] at /home/x3v0/gt/install/GD-2.16/blib/lib/GD/ line 49
Compilation failed in require at
/home/x3v0/gt/install/GD-2.16/blib/lib/GD/ line 49.
BEGIN failed--compilation aborted at
/home/x3v0/gt/install/GD-2.16/blib/lib/GD/ line 49.
Compilation failed in require at t/Polyline.t line 10.
BEGIN failed--compilation aborted at t/Polyline.t line 10.
        Test returned status 255 (wstat 65280, 0xff00)
        Failed 1/1 tests, 0.00% okay
Failed Test  Stat Wstat Total Fail  Failed  List of Failed
t/GD.t        255 65280    10   19 190.00%  1-10
t/Polyline.t  255 65280     1    2 200.00%  1
Failed 2/2 test scripts, 0.00% okay. 11/11 subtests failed, 0.00%
make: *** [test_dynamic] Error 255

I'm not sure exactly what is wrong, but it looks like it can't find Any ideas on what is going on and how to fix this error?


Site Timeline