GD installation

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I was trying to install the perl module GD-2.44 in a MacBook Pro
running Mac OS X version 10.6.2.  I've installed gd-2.0.35, which is
newer than the recommended 2.0.18.  I've also successfully installed
zlib-1.2.3, libpng-1.4.0, jpeg-8, and freetype-2.3.11 in /sw/lib and /
sw/include folder.  When I tried to run "make", there were "file is
not of required architecture" warnings for a number of files,
including /sw/lib/libiconv.dylib, GD.o, /sw/lib/libjpeg.dylib, /sw/lib/
libfreetype.dylib, etc.  Despite the warnings, make succeeded.  But
when I ran make test, there was an error message saying "Can't find
'boot_GD' symbol in ./blib/arch/auto/GD/GD.bundle at t/GD.t line 14".
There was another similar error message for t/Polyline.t.  Can anybody
please tell me what the problem is and how to fix it.  Thanks.  I
appreciate it.

Site Timeline