Filesys::SmbClient Build Errors

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I've tried building Filesys::SmbClient through CPAN on my workstation
and two development servers (running ubuntu and suse) to no avail.
Tried some patches/workarounds I found on google but those didn't work.
Any suggestions?

Relevant Output:

cpan> install Filesys::SmbClient
-fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2
-fsigned-char -fmessage-length=0 -Wall -Wall -pipe   -DVERSION=\"3.0\"
-DXS_VERSION=\"3.0\" -fPIC
"-I/usr/lib/perl5/5.8.3/s390x-linux-thread-multi/CORE"   SmbClient.c
SmbClient.c: In function `XS_Filesys__SmbClient__set_flags':
SmbClient.c:85: warning: unused variable `flag'
SmbClient.xs:191:60: macro "readdir" passed 2 arguments, but takes just
make: *** [SmbClient.o] Error 1
  /usr/bin/make  -- NOT OK
Running make test
  Can't test without successful make
Running make install
  make had returned bad status, install seems impossible
Failed during this command:
  ALIAN/Filesys-SmbClient-3.0.tar.gz           : make NO

Re: Filesys::SmbClient Build Errors

Quoted text here. Click to load it

Did you try the fix at .
You'll need to rebuild from scratch after you make any changes to


Site Timeline