Error installing Apache::Request

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I am recieving the error

mod_perl 1.x ( < 1.99) is required at Makefile.PL line 34.
BEGIN failed--compilation aborted at Makefile.PL line 36.

I've installed mod_perl and it says up to date

I am trying to install using perl -MCPAN -e 'install Apache::Request'

where do i begin to troubleshoot the problem?

thank you


Re: Error installing Apache::Request

Quoted text here. Click to load it

Looks like that error comes from:

    elsif ($mod_perl::VERSION > 1.98) {
        die "mod_perl 1.x ( < 1.99) is required";

from which I deduce that Apache::Request (or, more exactly, libapreq) won't
work with a version of mod_perl that is more recent than 1.98.


Site Timeline