Error 255 in make of mod_perl 1.29

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

make[1]: Entering directory `/home/josh/mod_perl-1.29/Apache'
Perl lib version (v5.6.0) doesn't match executable version (v5.8.5) at
/usr/lib/perl5/5.6.0/i386-linux/ line 21.
Compilation failed in require at /usr/lib/perl5/5.6.0/ExtUtils/
line 10.
BEGIN failed--compilation aborted at
/usr/lib/perl5/5.6.0/ExtUtils/ line 10.
Compilation failed in require.
BEGIN failed--compilation aborted.
make[1]: *** [pm_to_blib] Error 255
make[1]: Leaving directory `/home/josh/mod_perl-1.29/Apache'
make: *** [subdirs] Error 2

This is what I get when I try to run a make on mod_perl 1.29
Apache is 1.3.33
Perl is 5.6.0
Can someone tell me what I`m doing wrong?  This is after running the
Makefile.PL is just about every way imaginable that might plausibly work, I
cannot get around this.  I know it`s me screwing up, but I`m drawing a blank
and getting kind of desperate here.

Site Timeline