DBI_DB2 problems

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I have problems accessing my DB2 database via CGI in web application. I
am receiving this error:
install_driver(DB2) failed: Can't load
for module DBD::DB2: libdb2.so.1: cannot open shared object file: No
such file or directory at
/usr/lib/perl5/5.8.3/i386-linux-thread-multi/DynaLoader.pm line 229.
 at (eval 22) line 3
Compilation failed in require at (eval 22) line 3.
Perhaps a required shared library or dll isn't installed where expected
line 135

I have read on googlegroup that i should setenv the LD_LIBRARY_PATH in
my httpd.conf but i don't know how to do that.
Theres is nothing about that variable in my httpd.conf
Do you know how i can set that variable or is there any other solution?
thank you

Re: DBI_DB2 problems

enoumen@gmail.com wrote:
Quoted text here. Click to load it

It sounds to me like you think you have an Apache configuration problem.
If your CGI script runs interactively, I agree with you.

Have you tried reading the Apache documentation?

Have you tried asking in an Apache-oriented newsgroup?

Tom Wyant

Re: DBI_DB2 problems

Hi Harry,
thanks for your message. If this can help anyone, I took my chance and
i solved it by adding to my httpd.conf the line
setenv  LD_LIBRARY_PATH  /home/db2insts1/sqllib/lib which is the path
to the required DB2 library.

harryfmudd [AT] comcast [DOT] net wrote:
Quoted text here. Click to load it

Site Timeline