DBD::mysql module issue with Movable Type

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Hi everyone.

I am having some trouble with the installation of MT 4.3.2 on my Mac

I am able to get mt-check to run, but it says that DBD::MySQL module
is not installed. Here is what it says:

DBI (version >= 1.21)
Your server has DBI installed (version 1.52).

Your server does not have DBD::mysql installed, or DBD::mysql requires
another module that is not installed. The DBD::mysql database driver
is required to use MySQL Database. Please consult the installation
instructions for help in installing DBD::mysql.

However, when I run sudo cpan DBD::mysql it says that it is up-to-

CPAN: Storable loaded ok (v2.19)
Going to read /Users/.../.cpan/Metadata
Database was generated on Thu, 01 Jul 2010 04:28:19 GMT
DBD::mysql is up to date (4.014).

When I try to run mt.cgi I get an error:

install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC...

When I checked perl -V (or sudo perl -V) the @INC value doesn't
include the path that is listed by cpan for being correctly installed.

Is the issue that it is installed for me (user) rather than the
system? Do I need to reinstall the module? Have you come across this?

If it helps, I am using Mac OS 10.5.5 with MT 4.3.2.

Any help is greatly appreciated. I have been banging my head against
this for a few days now with nothing I can find working...


Site Timeline