Crypt::SSLeay and the C runtime

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I would like to get Crypt::SSLeay working so that I can make https

openssl seemed to install OK.

During the installation of Crypt::SSLeay, it fails test 02-live.t and
a runtime error window pops up saying:

"perl command line interpreter has encountered a problem and needs to
close. We are sorry for the inconvenience"

It seems to be finding the MS C runtime but getting an error whenit

I have tried with different versions of MSVCR80.dll and also tried
upgrading perl to but all with no effect.

Its probably something obvious but I have been stuck with this for a
while so any pointer appreciated.

Re: Crypt::SSLeay and the C runtime

Quoted text here. Click to load it

It's not exactly obvious, but the problem *could* be that your
compiler uses the MSVCR80.dll C runtime, whereas your perl uses a
different C runtime. For example, if you're using ActivePerl, then
perl is using the MSVCRT.dll C runtime. This will produce an
*irreconcilable* problem when a handle created by MSVCRT80.dll gets
passed to MSVCRT.dll (or vice-versa) as the receiving dll knows
nothing about the handle it has received.

In short, the compiler that built openssl and Crypt::SSLeay should be
using the same C runtime as perl itself. If you're running ActivePerl,
this means you should compile openssl and Crypt::SSLeay with either
MSVC++ 6.0 or the freely available MinGW port of gcc.
If you're committed to using your current compiler, you might have to
first build perl using that compiler (thus ensuring that perl uses

I did see somewhere that there's a free version of VC 8 that uses
MSVCRT.dll - it, too, would therefore be usable with ActivePerl (if
you can find it).

Have you considered installing Crypt::SSLeay using ppm ?
ppm install
That should also avoid the problem (... again, assuming ActivePerl),
though you might also need to avoid using the openssl dll that you
built (as it, too, will be using MSVCR80.dll).

There's also the possibility that the problem is totally unrelated to
the issues I've raised here :-)


Re: Crypt::SSLeay and the C runtime


Thanks for your very helpful posting.

Starting with the simplest step first, I tried reinstalling
Crypt::SSLeay using ppm.

It installed very sweetly then re-running my perl script with the
https call ran perfectly!

Previously I was trying to install Crypt::SSLeay manually.

I am very grateful to you for taking the time to reply and pointing
out the fairly obvious to one who is blundering around.

Best regards,


Quoted text here. Click to load it

Site Timeline