.CPAN Locked (OS 10.3.5)

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Okay this is way over my head, but this forum looks like the place i can

get some help. I am trying to run a perl script from my mac os computer,

but when i access the script it gives me the following error:

Can't locate URI.pm in @INC (@INC contains: libwww



/Library/Perl/5.8.1/darwin-thread-multi-2level /Library/Perl/5.8.1

/Library/Perl /Network/Library/Perl/5.8.1/darwin-thread-multi-2level

/Network/Library/Perl/5.8.1 /Network/Library/Perl .) at (eval 3) line


So i ran some searches on google and found the following to run in the

terminal which told me the permissions were wrong in the .cpan folder:

Your configuration suggests that CPAN.pm should use a working
directory of
Unfortunately we could not create the lock file
due to permission problems.

Please make sure that the configuration variable
points to a directory where you can write a .lock file. You can set
this variable in either

Could not open >/Users/asmith/.cpan/.lock: Permission denied

So i opened up transmit and tried to change the persmissions of the

folder but it wouldn't let me. I also tried changing the $CPAN variable

to a folder that can be written to but i am not sure which one will

work. Which brought me to this website. I hope someone can help me or

at least point me in the right direction so i can get this perl script

to run.


- Andy




Posted via http://www.codecomments.com



Site Timeline