Compress::Zlib installation

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View


I install Compress::Zlib 1.42 on Solaris 5.10.

make emits fatal error 'Command failed for target 'Zlib.o'.  The same
error for all zlib library options: zlib included in the module, zlib
preinstalled or zlib sources in the module installation
directory. Options set in

zlib library version: 1.2.3

Any suggestions?

Thank you.


Re: Compress::Zlib installation

rahed wrote:

Quoted text here. Click to load it

I need more information to help diagnose the problem you are having.

This is from the README file that comes with the Compress::Zlib
distribution. Also include a copy of the file you are using.

 4. If you are having problems building Compress::Zlib, send me a
    complete log of what happened. Start by unpacking the Compress:Zlib
    module into a fresh directory and keep a log of all the steps

        [edit, if necessary]
        perl Makefile.PL
        make test TEST_VERBOSE=1


Re: Compress::Zlib installation

Quoted text here. Click to load it

As P. Marquess suggested this was a Solaris 10 ggc issue with headers.
After applying fix according to the module got


Site Timeline