Cannot install DBI on Win2003 server - fails to locate dbi.ppd

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View


I'm attempting to install the latest DBI on a Windows2003 Advanced Server
version, using ActiveState perl 5.6.0

I have the DBI.ppd file, as well as the DBI.tar.gz file, but the PPM
installer can't seem to locate it.  I've spent quite a few hours searching
the net looking for more technical and in-depth info on how the PPM package
works, what directories it's searching and so on.  Nothing.

My perl distro is installed at D:\winforunix\Perl\.

I have the following relevent files at these locations:

My first question is: Which directory should I be in when I execute the '
ppm install DBI ' command?  (I've been issuing the command from
D:\winforunix\Packeges\ since that is where the ppd file is located.)

When installing, I get the following error:

Failed to load PPM_DAT file.
Error installing package 'DBI' : Could not locate a PPD file for package DBI

What is the "PPM_DAT" file in question?  (Where should it be located, and
what is the full filename?)  And why couldn't it locate the DBI.ppd file
when I'm in that current directory?  Is there some path list the ppm program
is following and I don't have my path setup correctly?

For reference, here's the first few lines of output when I execute 'perl -V'
on my system:

D:\winforunix\Packages>perl -V
Summary of my perl5 (revision 5 version 6 subversion 0) configuration:
    osname=MSWin32, osvers=4.0, archname=MSWin32-x86-multi-thread
    uname=' '

And here is the contents of my DBI.ppd file:

     <ABSTRACT>Database independent interface for Perl</ABSTRACT>
               <OS NAME>="MSWin32" />
               <ARCHITECURE NAME="MSWin32-x86-multi-thread" />
               <CODEBASE HREF="x86/DBI.tar.gz" />

I'm not sure why the version tag says "1,13,0,0" since I just downloaded the
1.48 version of DBI.  I have the ../x86/DBI.tar.gz file in place.  I've also
moved the .gz file into the D:\winforunix\Packeges directory and modified
the HREF tag in the ppd file, still same error.  I can't find any literature
or FAQs regarding the use of PPM, nor admin-level guides anywhere to figure
out what's up.  I suspect this is a PPM problem, not a DBI problem, not
sure.  Any help is appreciated.


Re: Cannot install DBI on Win2003 server - fails to locate dbi.ppd

Quoted text here. Click to load it

Yep - that should work with the ppd file you've provided below (assuming you
actually do have version 1.13 - otherwise I think you'll ultimately get a
version mismatch error of some sort).

Quoted text here. Click to load it

The pod documentation in ppm.bat (and possibly also ppm2.bat and ppm3.bat)
contains some info re PPM_DAT.
See if there's something there that helps.
perldoc ppm
perldoc ppm2
perldoc ppm3


Quoted text here. Click to load it

Where did you get it from ? Does the machine in question have access to the
internet ? (If so, there's no need to download ppm packages - you just run
'ppm install DBI' while connected to the internet.)
You might also try installing by running ppm2 or ppm3 instead of ppm.

Can you install any ppm packages at all ?



Re: Cannot install DBI on Win2003 server - fails to locate dbi.ppd

Rob, thanks for the reply.  My comments mixed below:

Quoted text here. Click to load it

After a bit of digging around, the version 1.13 is the .ppd file refering to
the my PPM version.

Quoted text here. Click to load it

Unfortunately no.  After reading 'perldoc ppm', I'm pretty sure the PPM_DAT
file is supposed to the the ppm.xml file.  I have that file, but PPM just
can't seem to locate it.  I've also attempted to use the ppm program to set
parmameters, except that it still needs to load the PPM_DAT file even when
I'm trying to configure it.

Quoted text here. Click to load it

I downloaded DBI-1.48.tar.gz from  However, the DBI.ppd file
came pre-installed with my diststribution.  Oh, I should mention the
particular server I'm attempting to install to is not connected to the
Internet.  It's a production box contained in the corporate LAN and access
to the general Internet is a no-no for this box.  However, I have admin
rights to the machine and can download files using my own workstation and
place the files on the server machine.

Quoted text here. Click to load it

No.  The PPM app itself is hosed, I guess.  The perldoc for PPM assumes
you've already set it up properly (without refering to any resource to
explain how to actually configure it.)


Re: Cannot install DBI on Win2003 server - fails to locate dbi.ppd

Quoted text here. Click to load it

That tarball you got from cpan won't work with the DBI.ppd file. The DBI.ppd
is looking for a file called DBI.tar.gz that contains something entirely
different. If DBI.ppd came with the distribution, then I would expect that
the distribution also contained the x86/DBI.tar.gz that it needs.

If you can't locate the DBI.tar.gz that your current DBI.ppd needs, then
download this DBI.tar.gz:

and try the following as your DBI.ppd file :

 <ABSTRACT>Database independent interface for Perl</ABSTRACT>
  <OS NAME="MSWin32" />
  <ARCHITECTURE NAME="MSWin32-x86-multi-thread" />
  <CODEBASE HREF="x86/DBI.tar.gz" />

That way you get a more up-to-date version.

Quoted text here. Click to load it

If you have ActiveState perl then it should come already-configured. (At
least it will be configured well enough to do the basic sort of stuff that
you are attempting.) Or have you tried to build ppm yourself ?


Site Timeline