Dead T3 - Request for help

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

My T3 seems to have died a sudden death...All was well two nights ago,
when I synched up with my desktop. Went to a holiday concert two nights
ago and put away my T3 when I retired for the evening. The next
morning, I tried to turn on T3 but nothing showed up on the
screen...just blank. Tapping the 5 keys in the front provided no
response either. Jammed the power button as hard as I could but no
response (funny design on the power button, eh?).

I figured that I might have hit the voice recorder accidentally the
previous night and must have drained the battery. Popped the T3 into
the cradle for a charge. The green power light came on. Tried to turn
on the T3 while in the cradle but no luck. Kept in the cradle for a few
hours but the unit still does not turn on. However, did notice
interesting behaviour yesterday. The T3 would display a flashing white
screen every 30-45 seconds and go dark while it was taken off the
cradle. It is as if the light on the PDA comes icons though.
The screen lights up for 2 seconds and goes away....saw it do that for
atleast a dozen times before I got bored watching it do that. Put away
the T3 for the day. Ran into this forum and discovered the different
type of resets that can be done. Tried them all with no luck. Finally,
opened up the unit and disconnected the battery and reconnected it.
Still no luck.

Interesting thing I noticed is that the reset button at the back is
acting like a toggle switch. Click it once and drop the T3 into the
cradle, the T3 turns on the green charging light. Take it out of the
cradle, the green light is still on. Click on the reset button at the
back. The green light goes away. Now slide the T3 into the cradle, the
green light does not turn on. Press the reset button again and the
green light comes on.....and repeat....

And, a couple of other clues. When connected to the desktop (USB
connection via the cradle), the XP Device Manager shows that the Palm
device is working fine. And new apps/software/tools have been
added to the device.

I am completely mystified and am out of ideas. Would appreciate
ideas/suggestions on how I could breathe life back into this unit.
Thanks in advance.


Site Timeline