Newbie seeks help using backup/restore

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Hello all,

I am attempting to bring over a MySQL database from a Windows XP server
to a Sun Solaris server. I seem to be having permission problems, but I
don't even know where to start.

NOTE: I have root access to MySQL, but cripplingly little access to the
server itself. If I knew what access to request, I could probably get
it, but I don't know
I was able to find the .frm files for the old database, as well as to
output a .sql backup file, and to store them on the new server. I tried
to restore them using the following steps:

[Login to MySQL as root user and enter password, then...]

USE mpf1;
RESTORE TABLE submitted_records FROM '/var/apache2/htdocs';

(Note: htdocs is one of the few places I have permission to access.)

And it said "error copying .frm file errno13" and failed to create the

So then I tried it again with FROM

same error. Ditto when I went and maxed out the permissions on those
.frm files.

Next, I tried creating a dummy database on the Solaris server and
backing it up to see whether I was having version/migration problems.

BACKUP TABLE dummy_table TO...

Same error.

Anyone have any ideas on where to go with this? I can ask the sysadmin
(at another location) for anything I like, so long as I know why I'm
asking for it...


Site Timeline