How can I make mysqld find the table '' on Fedora Core 4?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

    I'm trying to get mysql working on Fedora Core 4. Actually trying
to start the program mysqld without fatal errors. I posted this message
first on the linux misc group - but no luck so far. Maybe people on
this group can help me out. Sorry about posting to two groups.
    The reference manual for mysql ver 4.1 is huge, it's over 1900 pages!
I've tried all day but now I have to ask for help from people more
experienced then me.
    Anyway, this is what I have done: I changed ownership of the mysql
directory to my userid
ran the program mysqld without options - which did set up a few things,
but had fatal errors.
So, I tried again.
    Finally I read in the manual that if one's data directory is in a
different place then usual then the data directory must be given on the
command line or in a configuration (option) file.
I typed the command:  /usr/libexec/mysqld -datadir=/var/lib/mysql

The output (cut and pasted below) was:

060923 19:16:02  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
060923 19:16:02  InnoDB: Starting log scan based on checkpoint at
InnoDB: log sequence number 0 43634.
InnoDB: Doing recovery: scanned up to log sequence number 0 43634
060923 19:16:02  InnoDB: Flushing modified pages from the buffer
060923 19:16:02  InnoDB: Started; log sequence number 0 43634
060923 19:16:02 [ERROR] Fatal error: Can't open and lock privilege
tables: Table '' doesn't exist

Which brings me to the question:

How can I make mysqld find the table '' on Fedora Core 4?

second: Do I have to tell mysqld where the base directory is? And if
so, where would it be?

Any help appreciated!

- Tom Z

Site Timeline