Failing tests with Fedora Core 5 running on i386 but not x86_86

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Hi all

I build MySQL 5.0.24 as follows:

setenv PREFIX /data/mysql-5.0.24
setenv CXXFLAGS "$CFLAGS -felide-constructors -fno-exceptions -fno-rtti"
./configure \
   --prefix=$PREFIX \
   --enable-local-infile \
   --enable-largefile \
   --enable-thread-safe-client \
   --with-mysqld-user="mysql" \
   --without-debug \
   --with-comment \
   --with-vio \
   --with-openssl \
   --with-bench \
   --with-readline \
   --with-extra-charsets=complex \
   --with-berkeley-db \
   --with-archive-storage-engine \
   --with-csv-storage-engine \

configuring and making runs through without any problem but
'make test' fails with:
ctype_ucs_binlog               [ fail ]

Errors are (from /home/vali/prog/mysql-5.0.24/mysql-test/var/log/mysqltest-time) :
mysqltest: Result length mismatch
(the last lines may be the most important ones)
Below are the diffs between actual and expected results:
*** r/ctype_ucs_binlog.result   Thu Jul 27 22:03:41 2006
--- r/ctype_ucs_binlog.reject   Mon Aug 14 21:03:50 2006
*** 15,22 ****
   SET @@session.foreign_key_checks=1, @@session.sql_auto_is_null=1, @@session.unique_checks=1;
   SET @@session.sql_mode=0;
! /*!\C latin1 */;
! SET @@session.character_set_client=8,@@session.collation_connection=8,@@session.collation_server=8;
   insert into t2 values (@v);
   # End of log file
   ROLLBACK /* added by mysqlbinlog */;
--- 15,21 ----
   SET @@session.foreign_key_checks=1, @@session.sql_auto_is_null=1, @@session.unique_checks=1;
   SET @@session.sql_mode=0;
! SET @@session.auto_increment_increment=29811, @@session.auto_increment_offset=1124;
   insert into t2 values (@v);
   # End of log file
   ROLLBACK /* added by mysqlbinlog */;

I tried it on two machines running Fedora Core 5 with almost the
same packages installed. The one running x86_64 is happy but the
one running i386 fails.

uname -ripm:
- 2.6.17-1.2174_FC5smp i686 i686 i386
- 2.6.16-1.2133_FC5 x86_64 x86_64 x86_64

I tried it on two other boxes (with different package base) as well:
- 2.6.17-1.2157_FC5smp i686 i686 i386
- 2.6.17-1.2157_FC5 x86_64 x86_64 x86_64

Here, the kernel version is the same but the one running i386 fails
as well.

Forcing more tests (cd mysql-test ; ./mysql-test-run --force) brings
up more failures:

mysql-test-run in default mode: *** Failing the test(s): ctype_ucs_binlog mysql_client_test mysqlbinlog mysqlbinlog2 mysqlcheck mysqldump-max mysqldump mysqlshow query_cache rename rpl000002 rpl000005 rpl_auto_increment rpl_charset rpl_dual_pos_advance rpl_innodb rpl_insert_id rpl_insert_ignore rpl_loaddata rpl_log rpl_multi_update2 rpl_multi_update3 rpl_optimize rpl_replicate_do rpl_set_charset rpl_sporadic_master rpl_timezone rpl_trigger select show_check system_mysql_db system_mysql_db_fix user_var-binlog view

I also tried versions 5.0.22, 5.0.18, and 5.0.15 as well. Always
the same problem.

Any help/suggestions would be greatly appreciated!

Thanks, Valentin

Site Timeline