error connecting to db server

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I have a mysql 3.5 server installed on a suse linux 8.1, with address
Now I want to access that db from a W2K pc, address
I am able to ping, but I cannot connect to the db, and get error 2013.
I have tried with MySQL Administrator 1.0 and also with ODBC.
The db on linux has
grant all on *.* to ''@'10.0.0.%'
and also tried
... to root@
and others seen on posted messages.
I can access that db via php applications (eg phpMyAdmin).
Thank you.

Re: error connecting to db server

kamilla wrote:
Quoted text here. Click to load it

This seems to be a prevalent error with many causes.
Everything from library conflicts on the server, to exhausted disk
space, to the MySQL server simply being configured to deny remote

Does this occur immediately upon connecting to the MySQL server, or is
it only have you attempt some query or command on that connection?
Can other hosts connect to the MySQL server without this error?
Can clients on the Linux host connect to a MySQL database? (e.g. 'mysql
Can clients on the Linux host connect to a MySQL database using the
network layer (e.g. 'mysql -h test')
If you can connect from the Linux client, look at the values:
  mysql> show variables like 'skip_networking';
  mysql> show variables like 'bind_address';
If skip_networking is "Yes" or bind_address is anything other than
"" then this would prevent the connection.

Bill K.

Quoted text here. Click to load it

Re: error connecting to db server

Thank you.

On the Linux node:
I have more space available

'mysql test' and 'mysql -h test' give no error message,
seem to work.

mysql> show variables like 'skip_networking' = OFF
mysql> show variables like 'bind_address'; = Empty set

' ' or
' '
works and can access db

'MySQLAdministrator.exe' connect to server host =, user =
root, pwd = ''
gives 'could not connect to the specified instance', while ping works
Connection to another db on works
Other trials made with odbc connector tools, failed.
Same from

What else to check?
Thank you.
Nice w-e!

Quoted text here. Click to load it

Re: error connecting to db server

Does your host have a firewall that doesn't allow connections
on port 3306?   Try (from another machine) 'telnet 3306' and see
if you get a connection. The connection won't last long before MySQL
decides something is wrong and closes it, but you should see something
$telnet 3306

Escape character is '^]'.
4.1.11-Max=2!NH\tS,"OHZm6`eXj.DConnection closed by foreign host.

In this case, 4.1.11-Max is the database server version.  You should see
something about 3.5.xx.... that you should recognize as your MySQL version.

If you get 'connection refused', your firewall is blocking you.

Hope this helps.

Mike Argy
Custom Office solutions
and Windows/UNIX programs
Excel 2000 on Fedora Core 3

Site Timeline