cannot restore 3.23.58 db to MySQL 4.0.22-debug

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hello All,

The other day my server running MySQL 3.23.58 got hacked into and we
are migrating to another one. I backed up my databases using two
methods a) Mysqldump and b) copy the DATA folder on my server.

Now, I am trying to restore these databases on my local machine
(running MySQL 4.0.22-debug and Apache 2.0 on IIS 6.0). I have tried
importing the SQL files (mysqldump) and copying the .frm, .myd and .myi
files into the existing DATA folder on my local machine.

In both cases, the database is created and I can see the table
structure. But when I click on most of the tables, I get the following

#1016 - Can't open file: '<table_name>.InnoDB'. (errno: 1)

Can anyone pls throw some light on this issue? Any suggestion will be
greatly appreciated.

- V

Re: cannot restore 3.23.58 db to MySQL 4.0.22-debug wrote:
Quoted text here. Click to load it

I don't understand -- you did both?  One or the other should be the
solution, but not both.  Or did you mean that you tried one method of
restoratin, found it didn't work, and then tried the other with the same

Quoted text here. Click to load it

Similar issues discussed MySQL forums seem to state that this is caused
by mixing MyISAM table files (.frm, .myd, .myi) and InnoDB tables.  You
have .frm files for which there is no entry in the InnoDB tablespace file.

I'm guessing that when you restored your mysqldump files, it created the
database using InnoDB tables.  Then you put your .frm files in place,
which makes InnoDB think that you want to store the tables in one file
per table, instead of the default configuration of all tables in one
file.  Thus it became confused.

You can probably remove the .FRM, .MYD, and .MYI files (from the data
directory, not your originals!) and then restart MySQL.  The data is
probably all in <datadirectory>/ibdata1 at this time.

See also

Bill K.

Site Timeline