POP3 Authentication

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I hope this is the right group for this question.

I have successfully used POP3 to retrieve mail from my RH9 Linux Mail

Recently, I changed to Fedorea Core 3 and I find that I can't get
authentication of my password in order for POP3 to retrieve mail.

Has there been some changes to PAM that I need to be aware of ?

And comments would be appreciated.


Re: POP3 Authentication

OCDave wrote:
Quoted text here. Click to load it
Probably not.

Try posting with examples of what you tried, which clients you tested. Did
you check to see if it was listening on the right port. What error messages
are you getting. Run it through a proxy or packet sniffer or learn the POP
commands and try it using telnet. Go read Eric S. Raymonds 'How to ask
POP used to use clear text passwords - very insecure. I'm not very familiar
with RH., but its likely that cleartext auth is disabled.


Re: POP3 Authentication

You know, I don't know if I really want to post to you any more.

I asked a question, and expected - at least - courtesy - not a lecture
on "How to ask questions".

If you think I'm not presenting my problem to the right group, why
should I provide you with error messages ? And if you're not very
familiar with RH, why did you respond ?

But, for your information, before bothering you with my question to the
wrong group, I did check if Port 110 was used, I did telnet localhost
through port 110 and entered a dialogue and got an error message - the
same error message from Red Hat 9 - but POP3 works on that server

Anyway, I'll leave you and your snide attitude alone now.

And I'll skip reading Eric S. Raymonds "How to ask questions"


Re: POP3 Authentication

On 26/05/2006 00:52, OCDave wibbled:
Quoted text here. Click to load it

Why did you telnet localhost? Surely you should be telneting your POP3
mail server?

e.g. telnet mail.garbage.uk 110

Once you did that, you need to enter at the command line:

user fred@garbage.uk


pass [your password] (without the brackets)

Should then be connected to your POP3 server, and you can use LIST RETR
DELE, etc, etc...

Quoted text here. Click to load it

Sorry about the other response - just killfile him.

Quoted text here. Click to load it

No, you should seriously consider reading _everything_ that Eric has

And yes, YES - I know I'm posting from Windoze!!

Quoted text here. Click to load it

Re: POP3 Authentication

Thanks for yur reply.

First, I am trying to set up POP3 on a Red Hat Fedora Core 3 machine

I was using "Linux Troubleshooting Bible" by Christopher Negus.

ON page 508, here is what he says to do :

telnet localhost 110

When you get acknowledgment , enter "user .. my name"

The returning prompt is "OK  username accepted, password please"

I enter my password and get the message

"ERR Unknown AUTHORIZATION State Command"

I tried your method, but I get the same ERR message.

What is strange is when I enter the same commands on my Red Hat 9
where POP3 DOES work, I get the same error message - but I can use POP3
just fine to get my mail to my workstation.

POP3 files are installed in the following locations

/etc/pam.d/pop and /etc/pam.d/pop3

Any help would be appreciated.


Re: POP3 Authentication

On 27/05/2006 01:27, OCDave wibbled:
Quoted text here. Click to load it

Could this help?

Re: POP3 Authentication

Hi -

Quoted text here. Click to load it

Did you just enter your password alone or did you enter the command
"pass" (without the quotes) followed by a space followed by the actual

The latter is correct.  The former will cause the server software to
attempt to interpret your password as a command.

http://www.kensims.net /

Site Timeline