Joining Samba to a Windows Domain

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I just installed a Fedora Core 3, kernel 2.6 (actually 2.6.9-2.667, but
hell, who's counting?)
I am now completely unable to use samba.

Previously, with the 2.4 kernel, after carefully configuring the
smb.conf file, I joined the Windows active directory domain by saying:

smbpasswd -j<DOMAIN_NAME> -r<SERVER-NAME> -Uadministrator

the 2.4 kernel responded by asking for the admin password, and then it
graciously gave all the allowed windows workstations access to the
files on the Linux system as if they were on the PDC

With the 2.6 kernel, smbpasswd no longer has the -j option.

So how does one make the Linux box join the Windows domain????

I have studied the net command, and experimented around with numerous
suggestions found on the web, all to no avail.

I have surfed the web to no avail, so I once again humbly beseech you
all for wisdom about this new tribulation.

Happy Holidays.
- Frank

Re: Joining Samba to a Windows Domain

doc_rudolph wrote:
Quoted text here. Click to load it

net ads join -W <domain> -S <domain-controller> \
    -U <domain-administrator>

net rpc join -W <domain> -S <domain-controller> \
    -U <domain-administrator>

That is what I use.

Use the 'net ads' join for W2K ADS or higher.

Make sure your smb.conf has things setup as well.

Re: Joining Samba to a Windows Domain

I tried this:
net ads join -W <domain> -S <domain-controller>  -U
Filling in the blanks:
[root@localhost MasterController]# net ads join -Wbconcorp -Sbreakaway
Administrator's password:*****

This did not work. Here is the error message:
[2005/12/22 08:35:49, 0] libads/kerberos.c:ads_kinit_password(136)
  kerberos_kinit_password Administrator@BCONCORP.COM failed: Cannot
find KDC
for requested realm
[2005/12/22 08:35:49, 0] utils/net_ads.c:ads_startup(186)
  ads_connect: Cannot find KDC for requested realm

So I tried the minimalist version:

[root@localhost MasterController]# net rpc join -Uadministrator
Joined domain BCONCORP.

This seemed really promising. The above APPEARED to work, but I still
get the message:

"Flywheel3 is not accessible
    Access Denied"

when I try to browse the network neighborhood icon for the samba
server, Flywheel3.

Later, after the Windows domain refreshed itself, the message changed

"There are currently no logon servers available to service the logon

What exactly is the domain server looking for? Something on the Linux
side or
on the Windows side?

Thanks - Frank

Site Timeline