issue reg NATing using iptables

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Greetings ,

    I am trying to configure NATing with iptables on Fedora Core 6 box
with NICs.

    For this I am trying to execute the command.
    iptables -t NAT -A POSTROUTING -o eth0 -j MASQUERADE

   But it gives me the following error.

 iptables v1.3.8: can't initialize iptables table `NAT': Table does
not exist (do you need to insmod?)  Perhaps iptables or your kernel
needs to be upgraded.

I loaded the following modules .

iptable_nat               11845  0
ip_nat                     22253   2      ipt_MASQUERADE,iptable_nat
ip_conntrack           56993   5
nfnetlink                11353  2         ip_nat,ip_conntrack
ip_tables               17669  2         iptable_nat,iptable_filter
x_tables                18501  8

After loading the modules , I am still getting the same error.

 Please tell me where I am wrong. Do I have to install more modules ,
if then please
 let me know the name of the modules.

 With thanks in Advance

Re: issue reg NATing using iptables wrote:
Quoted text here. Click to load it

iptables -t nat

(lower case)

should do the trick.


Quoted text here. Click to load it

Re: issue reg NATing using iptables

Greetings Robert ,

Quoted text here. Click to load it

   Thanks for the quick reply . It worked .
   That was a silly mistake I did .


Site Timeline