Announcing LinuxSA 1.0.0 Beta

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
We are pleased to announce the availability of Linux Security Assessment (LinuxSA) v1.0.0 Beta.

LinuxSA is a tool for assessing the security settings of a Linux server or workstation. It is an automated program written in Python which analyzes the settings of a target Linux machine and then can provide a PDF report with the results of the scan.

The tools are easy to use and have a very small learning curve. The requirements are also small - you only need Python 2.7 or later and the Publican document system (available on most distributions) in order to assess and create the report.

It has been tested on a number of Linux distributions including

Red Hat 6 and 7
CentOS 7
Fedora 20 and 21
openSUSE 13.2
SuSE 11 and 12
Ubuntu 14.10
Linux Mint 17.1

Please visit our web site at to download the beta tar or zip file.

W. David Ashley <w dot david dot ashley at gmail dot com>  

Re: Announcing LinuxSA 1.0.0 Beta

Quoted text here. Click to load it

"future feature print_function is not defined" when run with Python 2.5
such as is found in RHEL 5. That function was not available until 2.7.  

Re: Announcing LinuxSA 1.0.0 Beta

You can still assess a RHEL 5 system by loading LibuxSA on a system with Python 2.7 or greater and then remotely asses the RHEL 5 system.

Site Timeline