XP Power Scheme Problem

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

Two Dell laptops - precision m4300 and a latitude d830. Both are running
win xp sp3.

I cannot get either machine to step down its cpu speed (either when on
ac or battery) when using a power scheme, such as portable/laptop, that
should provide cpu throttling (speedstep) depending on cpu load.
Speedstep is enabled in the BIOS.

Any ideas as to why this is not working?


Re: XP Power Scheme Problem

Quoted text here. Click to load it

How are you monitoring the speed? If you're just checking the reading on
System Properties dialog box, it may falsely show higher speed than is
actually in use most of time. I suppose that's because opening the
dialog box momentarily brings load to the cpu, and the load often
(something like 4 times out of 10) is enough to trigger the cpu to
switch to higher speed. And the reading in System Properties is only
updated while opening the box, so that's a problem in this method. I use
a program named CPU-Z (from www.cpuid.com) that keeps updating the cpu
speed reading without causing too much load.

CPU throttling doesn't seem to work so great anyway (at least on I've
used: Dell Latitude and Acer Aspire) -- it seems to be standard behavior
that some of the power schemes enable cpu throttling on AC and some on
battery, but none of them enables it on both. For example my normal
everyday power scheme for running laptop on AC is "Portable/Laptop",
which enables throttling while on AC. But when I'm using the laptop on
battery, I'll switch it to "Home/Office Desk" to get speedstep to save
battery power.

But if you have tried different schemes and if with none of them
speedstep is enabled neither on AC nor on battery, then I've run out of


Re: XP Power Scheme Problem

P.V. wrote:
Quoted text here. Click to load it
Some more info. Other features seem to work. Both task manager and
I8kfanGUI show no throttling with no cpu loading. Also, Device Manager
shows 2 processors (both machines are core 2 duo).

I also tried out Mobilemeter and found some strange results. If I had it
check cpu frequency via the "measure actual" it showed no throttling. If
I selected an OS base measurement method it showed throttling taking
place. I also tried cpumon - it indicated that no throttling was taking
place. I just now tried CPU-Z. It showed that all my power schemes were
throttled - even those that should not be.


Site Timeline