Toshiba Satellite 2805-S503 won't charge battery

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Toshiba Satellite 2805-S503 several years old won't charge the battery.
The LED flashes amber (it's lit for most of a second, off for only a
very small fraction of a second, repeat). Power Meter in Control Panel
shows the battery at 3%. I bought a replacement battery on ebay, Power
Meter shows that at 35% but it never increases and the LED flashes the
same way.

I remember when it was new the battery never really lasted very long,
two hours maybe. I ran it from AC quite a lot (without removing the
battery - I'd never heard that you should until reading this group this

Figure something is wrong with the charging circuitry? Any way to
diagnose this?

Re: Toshiba Satellite 2805-S503 won't charge battery

Even though you bought a 2nd battery (a used battery ... very
important), my bet would be more that the batteries are bad than that
the laptop is bad.  But it's still quite possible that the charging
circuit in the laptop is bad.  The only way to know for sure is to try a
known good battery (any used battery bought on E-Bay is, unfortunately,
suspect).  Two hours is about all that you can expect from a fully
charged new battery.  That laptop normally came with a 2487 series
battery (PA2487U-xx was the actualy p/n), but it will also take the
higher capacity 3107 series battery (which is nothing but a higher
capacity 2487).

Jeff wrote:
Quoted text here. Click to load it

Re: Toshiba Satellite 2805-S503 won't charge battery

After reading another post here, I blew compressed air thru the laptop,
probably the first time I've ever done it. After that, it was able to
charge the battery I got from ebay. Still won't charge the old one
(guess it's dead). Don't know exactly why it worked, but problem solved

Site Timeline