Thinkpad a31p hangs

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
My thinkpad a31p has started freezing regularly, usually within 10
minutes of booting windows2000 / linux. It also occasionally fails to
get to the POST screen; it powers on but the screen stays blank and
there's no HDD activity. I dropped it around a year ago, cracking the
case a little, but it still worked 100% until a week or so ago.

Things I've tried:
 - Removing the ethernet, wifi and bluetooth cards (no change)
 - Removing the DVD drive (no change)
 - memtest86 (no errors found)
 - PC doctor (no errors found)
 - Moving the memory to the other slot (no change)
 - Taking it apart and looking for damage (none found)
 - Turning graphcs acceleration to minimum in windows (no change)
 - Switching off HDD DMA and write-buffering in windows (no change)
 - Fiddling with the BIOS (no change)
 - Monitoring the CPU temperature (45c when it hangs)
 - Shaking it to see if that triggers a hang (it doesn't)

The laptop is perfectly functional until it hangs. Oddly, neither PC
Doctor nor memtest86 hang however long I let them run.

Can anyone suggest anything else I can try? I'm tearing my hair out

Re: Thinkpad a31p hangs (Mike Ferenduros) writes:
Quoted text here. Click to load it

Sounds like a hairline crack in a PC trace, that got worse and worse.

Quoted text here. Click to load it

Does the temperature ever reach 45c running memtest86?  And it doesn't
hang?  When the cpu reaches 45c, is the fan running full speed?

Quoted text here. Click to load it

Remove the system board and examine every PC trace carefully with a
magnifying glass, for one thing.

Re: Thinkpad a31p hangs

Thanks for the suggestions everyone!

memtest86 runs a lot hotter that windows or linux (as measured by
sticking my hand in front of the fan), with the fan going full blast.
In windows, the fan comes on at around 60c, and since posting I've seen
hangs at a wide range of temperatures. So I don't think CPU temperature
is the issue here.

There's no graphical corruption evident, everything just freezes.

The hairline crack suggestion is a bit scary - I had a closer look at
the system board today but couldn't spot anything.

I'm currently running knoppix with the HDD removed, as suggested by
another poster, and I haven't seen a crash yet.

So my next question is, if the system proves 100% stable with the HDD
removed, which of the following is my best bet?

1) Replace the HDD (£100)
2) Replace the system-board (£100)
3) Move the HDD to an ultrabay (£50 for the adaptor)
4) Hand it off to a repair shop (£???)
5) Chuck it and get a T42p (£more than I can afford, sadly)

Further advice would be very much appreciated...if anyone can suggest a
*good* repair shop in Manchester or London (UK) that'd be pretty
helpful too, although I'm seeing that as a last resort.

Re: Thinkpad a31p hangs wrote:
Quoted text here. Click to load it

Have you run tests on the HD? That's what it sounds like to me after all of
your other testing.

If you've got an IBM/Hitachi HD get the Drive Fitness Test from the Hitachi
support site and run it.



Re: Thinkpad a31p hangs

Quoted text here. Click to load it

You're running PC Doctor off of a CD, I take it?  If so, my best guess
is the hard drive.  Two ways to test this hypothesis: 1) get your hands
on another laptop hard drive; or 2) remove the hard drive, and boot from
a Linux LiveCD such as Knoppix, and see whether it still hangs.

Is there any corruption on the screen when it happens?  I guess some
video card issue might also be to blame.  I'm thinking it's probably
not the CPU since 1) memtest86 doesn't have any problems and 2) both
Linux and Windows boot up fine, but hang later.  Often, CPU issues
will cause the OS to freeze as it's booting up.

Other than that, I really can't think of anything.  It seems you've
been pretty thorough.  And we can eliminate many possible causes since
you're running both Windows and Linux and seeing the same problem with
both OSes.

Re: Thinkpad a31p hangs

On 28 Jan 2005 14:03:48 -0800, (Mike
Ferenduros) wrote:

Quoted text here. Click to load it

Same thing happen to me for 3 weeks now, with my more than 4 years old
A20P running Win2000.  I thought it was the heat build up, now all the
bottom covers are removed.  The memory chip don't seem to sit to well
I thought, swop them, use just one, try the other.  Swop with
different harddisks, including the one in the ultrabay.  Still did not
start.  Did all sorts of things to coax the bugger to start, that
work, but only for a few times.  Took out the cmos battery, make it
forget what the last boot config was, the bloody thing seems to know I
was trying to trick it.  I did realise that when I manage to boot up
sometimes, the ultrabay drive gave more info, like the registry was
not there, must have got wipe out when it went down.

Well, it is working now, but don't know for how long.  What I did was
use PartitionMagic to copy the a working Win2000 partition from one
disk to another and boot it up from there.  I find using the recovery
CD does not work too well when there are multiple partitions on the
harddisk.  It does not install full because the process creates a
temporary drive and the poor guy got confuse with the drive letters
and and not know what to do properly on reboot.  When the system
finally startup I send it into config mode, change the quick boot
option into diagnostics.  I think I might have found the problem,
fingers crossed for now.  This time it showed the 2 memory dimm did
not verify correctly, quick boot shows nothing of this sort.  My guess
is when it did run, the memory checksum failed after some time,
hanging the system.  Very trickly, because you can never tell what the
system was doing when it died and on one occasion, it wipe out some of
the files and some files did not close properly.

So I will be sending it to the workshop next month when I return from
my break, maybe the thermal rubber is wearing out and retaining heat,
and also seriously looking at a Dell, eg. the Inspiron 6000.

Re: Thinkpad a31p hangs

Mike Ferenduros schrieb:

Quoted text here. Click to load it
Any updates of OS, Patches from Microsoft installed?
Updated BIOS to the latest version? Some BIOS have problems with W2K or
XP. Look at support on!
Greets from Germany

Re: Thinkpad a31p hangs

I'm having the similar problem with my a31p.

I'm running w2K most of the time (Linux sometimes) and what I get is the

- System freezes, no response from any keys. Display still shows.
Holding power down for 4 sec will shut down system. Usually happens when
I am using it at home on my lap and using trackpoint.  Never (or it is
almost never, can't remember) happens when it is in the docking bay,
closed up, with external USB mouse, PS/2 keyboard and external monitor.

- Startup fails. After pressing the power some lights come on but the
system never boots. Pressing power again shuts it off.
Repeatedly doing this (3-10 times) usually gets it to boot.

- Occasionally blue screen of death, stop message, system displays blue
screen for about 1 sec then reboots. (maybe once per week)

I turned off speedstep, CPU Power management and PCI Bus Power
management but it failed to boot again shortly after that. About 6 tries
with the power button got it going.

If anyone else has any ideas I would love to hear them.


Mike Ferenduros wrote:
Quoted text here. Click to load it

Site Timeline