Synaptics Touchpad doesn't work anymore on my Acer Aspire 1690

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I have the following Problem with my Touchpad and my Acer Aspire 1690

When I first used my Laptop everything was fine. Also my Synaptics
Touchpad worked properly.

Somewhen I bought a USB mouse because a mouse is more comfortable then
a touchpad. For a few dasy I never used the touchpad again, but I know
that the touchpad and the mouse onece worked properly together... so I
could use either one... One day I wanted to use the touchpad again.
AND: It didn't work.

I downloaded the most actual drivers from the Acer webseite. I
installed them, everything seems to be fine, but the touchbad just
doesn't work.

In the hardware configuration are no conflicts displayed, the hardware
is not disabled or something like that. It is shown that the device is
"Ready To Work"  and that the drivers are fine.

The drivers load on system startup. So that also can't be the

Did someone had the same problem?

I don't know what to do... Thanks a lot for your help


Re: Synaptics Touchpad doesn't work anymore on my Acer Aspire 1690

Quoted text here. Click to load it

Check BIOS setup for a setting to disable the on-board pointing device.
Enable it.  F2, DEL, ESC, F10, or whatever key your laptop uses at boot,
before the Windows loading graphic, to access BIOS setup.


Site Timeline