Strange problem when loading web pages

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I just took delivery of a 9th user laptop. It's a Compaq M300. Nothing
special about it except that it is nice and light and above all else,
it was cheap, lol.
It came pre-installed with Win2K and the COA. After installing AVG and
all the usual security stuff I updated W2K to SP4,  IE5 to IE6 and
also installed Maxthon which is the browser I normally use on my main
Then, without any messing about with security settings, I plugged in
an ethernet cable from my home network router and clicked the IE icon.
As expected, the MSN home page appeared within at most 3 seconds. Then
I put  into the address bar and clicked GO and again,
it appeared almost instantly. All well and good so far but then I
tried eBay and it all started going wrong. The main eBay page fired up
quick as you like but clicking anything on the eBay home page brought
up the hour glass symbol and the progress bar at the bottom won't go
any further than 38%
I tried the main PC to see if was a fault with eBay of the connection
but the main PC loaded any kind of eBay page at the usual speed. I
tried it with Maxthon with the same result..... 38%.
Then I checked the security settings etc by clicking tools >> internet
options >> on the main PC and matched them all on the laptop and tried
again with the same result ... 38%

Compaq M300, 320 RAM, 600mhz.

Anybody any ideas?

Re: Strange problem when loading web pages

Quoted text here. Click to load it

are you on DSL broadband?  if so, change your MTU.  google for "TCP
Optimizer" - it'll do it for you.

Re: Strange problem when loading web pages

After checking the whole thing over and over again I found the
The original W2K came with IE5. I THOUGHT I had updated to IE6 but for
some reason or other the download and install did not complete. Once I
got IE6 ps1 installed properly, it all works fine and all web pages
load with the speed of light..
(IE6 is the latest version I can use with W2K)

Site Timeline